aboutsummaryrefslogtreecommitdiff
path: root/emulators/gns3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/gns3/Makefile')
-rw-r--r--emulators/gns3/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/emulators/gns3/Makefile b/emulators/gns3/Makefile
index 9c79326a82f8..4dde14570a00 100644
--- a/emulators/gns3/Makefile
+++ b/emulators/gns3/Makefile
@@ -1,4 +1,4 @@
-# Update ports collection makefile for: gns3
+# New ports collection makefile for: gns3
# Date created: 24 may 2009
# Whom: Olivier Cochard-Labbe <olivier@cochard.me>
#
@@ -6,8 +6,7 @@
#
PORTNAME= gns3
-PORTVERSION= 0.6.1
-PORTREVISION= 3
+PORTVERSION= 0.7
CATEGORIES= emulators
MASTER_SITES= SF/gns-3/GNS3/${PORTVERSION}
DISTNAME= GNS3-${PORTVERSION}-src
@@ -19,7 +18,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4
${PYTHON_SITELIBDIR}/PyQt4/QtSvg.so:${PORTSDIR}/graphics/py-qt4-svg \
${PYTHON_SITELIBDIR}/PyQt4/QtNetwork.so:${PORTSDIR}/net/py-qt4-network \
dynamips:${PORTSDIR}/emulators/dynamips-devel \
- dynagen:${PORTSDIR}/emulators/dynagen
+ dynagen:${PORTSDIR}/emulators/dynagen \
+ qemu>=0.11:${PORTSDIR}/emulators/qemu
USE_PYTHON= 2.4+
USE_PYDISTUTILS= YES
@@ -31,4 +31,6 @@ post-install:
.if !defined(NO_INSTALL_MANPAGES)
${INSTALL_MAN} ${WRKSRC}/docs/man/gns3.1 ${MANPREFIX}/man/man1
.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/qemuwrapper/qemuwrapper.py ${PREFIX}/bin/qemuwrapper.py
+
.include <bsd.port.mk>