aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-peops-softgpu
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux-peops-softgpu')
-rw-r--r--emulators/linux-peops-softgpu/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/emulators/linux-peops-softgpu/Makefile b/emulators/linux-peops-softgpu/Makefile
index cc520d34417a..d54d0978b4bd 100644
--- a/emulators/linux-peops-softgpu/Makefile
+++ b/emulators/linux-peops-softgpu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= peops-softgpu
PORTVERSION= 1.16
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= http://www.pbernert.com/
PKGNAMEPREFIX= linux-
@@ -19,22 +20,20 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
MAJOR= ${PORTVERSION:R}
MINOR= ${PORTVERSION:E}
PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
.include <bsd.port.pre.mk>
-PSEMUPRO_PLUGINS_DIR= ${LOCALBASE}/lib/psemupro/plugins
-PSEMUPRO_CFGBINS_DIR= ${LOCALBASE}/libexec/psemupro/cfg
-PSEMUPRO_CFGFILES_DIR= ${LOCALBASE}/share/psemupro/cfg
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
do-install:
${MKDIR} ${PSEMUPRO_PLUGINS_DIR}