aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-pete-mesagpu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux-pete-mesagpu/Makefile')
-rw-r--r--emulators/linux-pete-mesagpu/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/emulators/linux-pete-mesagpu/Makefile b/emulators/linux-pete-mesagpu/Makefile
index 62376601c190..5794a7898ed4 100644
--- a/emulators/linux-pete-mesagpu/Makefile
+++ b/emulators/linux-pete-mesagpu/Makefile
@@ -9,9 +9,9 @@ PORTNAME= pete-mesagpu
PORTVERSION= 1.75
PORTREVISION= 1
CATEGORIES= emulators linux
-MASTER_SITES= http://home.t-online.de/home/PeteBernert/
+MASTER_SITES= http://www.pbernert.com/
PKGNAMEPREFIX= linux-
-DISTNAME= gpupetemesagl175
+DISTNAME= gpupetemesagl${MAJOR}${MINOR}
MAINTAINER= jylefort@brutele.be
COMMENT= A PSEmu Pro GPU plugin using an OpenGL renderer (Linux version)
@@ -29,6 +29,10 @@ ONLY_FOR_ARCHS= i386
# because as a side effect it brands the binary as FreeBSD.
STRIP=
+MAJOR= ${PORTVERSION:R}
+MINOR= ${PORTVERSION:E}
+PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
+
.include <bsd.port.pre.mk>
PSEMUPRO_PLUGINS_DIR= ${LOCALBASE}/lib/psemupro/plugins
@@ -37,7 +41,7 @@ PSEMUPRO_CFGFILES_DIR= ${LOCALBASE}/share/psemupro/cfg
do-install:
${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/libgpuPeteMesaGL.so.1.0.75 ${PSEMUPRO_PLUGINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/libgpuPeteMesaGL.so.${MAJOR}.0.${MINOR} ${PSEMUPRO_PLUGINS_DIR}
${MKDIR} ${PSEMUPRO_CFGBINS_DIR}
${INSTALL_PROGRAM} ${WRKSRC}/cfgPeteMesaGL ${PSEMUPRO_CFGBINS_DIR}