aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-f8/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux_base-f8/Makefile')
-rw-r--r--emulators/linux_base-f8/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/emulators/linux_base-f8/Makefile b/emulators/linux_base-f8/Makefile
index 4e42bfbfea76..078a911f539c 100644
--- a/emulators/linux_base-f8/Makefile
+++ b/emulators/linux_base-f8/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fc7
PORTVERSION= 7
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
MASTER_SITE_SUBDIR= ../releases/${PORTVERSION}/Everything/${LINUX_RPM_ARCH}/os/Fedora
@@ -128,6 +129,8 @@ REMOVE_DIRS= boot dev home initrd root tmp var/log var/run var/tmp \
REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
etc/motd etc/passwd etc/printcap etc/services \
etc/protocols
+ADD_DIRS= usr/X11R6/share usr/X11R6/man usr/X11R6/lib/tls \
+ usr/X11R6/include usr/X11R6/bin
ADD_FILES= #empty
.if (${MACHINE_ARCH} == "amd64")
@@ -148,6 +151,9 @@ do-build:
@for F in ${REMOVE_FILES}; do \
${RM} -f ${WRKSRC}/$$F; \
done
+ @for F in ${ADD_DIRS}; do \
+ ${MKDIR} -p ${WRKSRC}/$$F; \
+ done
@for F in ${ADD_FILES}; do \
${TOUCH} ${WRKSRC}/$$F; \
done