aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-rh-9
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux_base-rh-9')
-rw-r--r--emulators/linux_base-rh-9/Makefile168
-rw-r--r--emulators/linux_base-rh-9/distinfo.i38634
-rw-r--r--emulators/linux_base-rh-9/files/yp.conf15
-rw-r--r--emulators/linux_base-rh-9/pkg-descr8
-rw-r--r--emulators/linux_base-rh-9/pkg-install34
-rw-r--r--emulators/linux_base-rh-9/pkg-message12
6 files changed, 0 insertions, 271 deletions
diff --git a/emulators/linux_base-rh-9/Makefile b/emulators/linux_base-rh-9/Makefile
deleted file mode 100644
index a11192fdc9f0..000000000000
--- a/emulators/linux_base-rh-9/Makefile
+++ /dev/null
@@ -1,168 +0,0 @@
-# New ports collection makefile for: linux_base-8
-# Date created: 2003-06-02
-# Whom: trevor
-# based on ports/emulators/linux_base by Marcel Moolenaar and others
-#
-# $FreeBSD$
-#
-
-PORTNAME= linux_base-8
-PORTVERSION= 8.0
-PORTREVISION= 2
-CATEGORIES= emulators linux
-MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
-MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
-DISTFILES= redhat-release-8.0-8.noarch.rpm \
- ${RPM_SETUP} \
- filesystem-2.1.6-5.noarch.rpm \
- basesystem-8.0-1.noarch.rpm \
- libattr-2.0.8-3.${MACHINE_ARCH}.rpm \
- libacl-2.0.11-2.${MACHINE_ARCH}.rpm \
- libelf-0.8.2-2.${MACHINE_ARCH}.rpm \
- bzip2-libs-1.0.2-5.${MACHINE_ARCH}.rpm \
- termcap-11.0.1-13.noarch.rpm \
- compat-db-3.3.11-2.${MACHINE_ARCH}.rpm \
- db4-4.0.14-14.${MACHINE_ARCH}.rpm \
- ${RPM_GDBM} \
- glib-1.2.10-8.${MACHINE_ARCH}.rpm \
- libtermcap-2.0.8-31.${MACHINE_ARCH}.rpm \
- bash-2.05b-5.${MACHINE_ARCH}.rpm \
- ${RPM_BZIP2} \
- ${RPM_LIBSTDCXX} \
- ${RPM_COMPAT_LIBSTDCXX} \
- ncurses-5.2-28.${MACHINE_ARCH}.rpm \
- info-4.2-5.${MACHINE_ARCH}.rpm \
- grep-2.5.1-4.${MACHINE_ARCH}.rpm \
- fileutils-4.1.9-11.${MACHINE_ARCH}.rpm \
- popt-1.7-1.06.${MACHINE_ARCH}.rpm \
- readline-4.3-3.${MACHINE_ARCH}.rpm \
- ${RPM_SETSERIAL} \
- libstdc++-3.2-7.i386.rpm \
- slang-1.4.5-11.${MACHINE_ARCH}.rpm \
- sh-utils-2.0.12-3.${MACHINE_ARCH}.rpm \
- rpm-4.1-1.06.${MACHINE_ARCH}.rpm \
- libgcc-3.2-7.${MACHINE_ARCH}.rpm \
- ${RPM_FREETYPE}
-
-PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
-PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
-PATCHFILES= ${UPDATES}
-
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= Base set of packages needed in Linux mode (only for i386)
-
-EXTRACT_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-
-RESTRICTED= "binaries under GNU GPL without accompanying source"
-CONFLICTS= linux_base-*
-ONLY_FOR_ARCHS= i386
-DIST_SUBDIR= rpm/${MACHINE_ARCH}/${PORTVERSION}
-PREFIX= ${LINUXBASE}
-NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
-NO_MTREE= yes
-PLIST= ${WRKDIR}/pkg-plist
-MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
-
-# Let's avoid hardcoding 'en' as the language.
-LANG= en
-
-UPD_SET1= glibc-common-2.3.2-4.80.6.${MACHINE_ARCH}.rpm \
- glibc-2.3.2-4.80.6.${MACHINE_ARCH}.rpm
-UPD_SET2= zlib-1.1.4-8.8x.${MACHINE_ARCH}.rpm
-UPDATES= ${UPD_SET1} ${UPD_SET2}
-
-.ifdef USE_LINUX
-.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
-
-.include <bsd.port.pre.mk>
-
-RPM_BZIP2= bzip2-1.0.2-5.i386.rpm
-RPM_FREETYPE= freetype-2.1.2-7.i386.rpm
-RPM_GDBM= gdbm-1.8.0-18.i386.rpm
-RPM_LIBSTDCXX=
-RPM_COMPAT_LIBSTDCXX= compat-libstdc++-7.3-2.96.110.i386.rpm
-RPM_SETSERIAL= setserial-2.17-9.i386.rpm
-RPM_SETUP= setup-2.5.20-1.noarch.rpm
-
-DBPATH= /var/lib/rpm
-RPM= LC_ALL=C rpm
-RPMFLAGS= --root ${WRKSRC} --dbpath ${DBPATH} --nodeps \
- --replacepkgs --ignoreos --ignorearch
-RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
-
-REMOVE_DIRS= boot dev home initrd root tmp var/tmp usr/local usr/tmp
-REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
- etc/motd etc/passwd etc/printcap etc/services \
- etc/protocols
-BRAND_FILES= bin/rpm sbin/ldconfig sbin/sln
-
-FALLBACK_ELF_MIB= kern.fallback_elf_brand
-LINUX_ELF= 3
-PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
-
-do-patch:
- @${DO_NADA}
-
-do-extract:
-#
-# Handle the loading of the linux loadable kernel module if required.
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
- @${MKDIR} ${WRKSRC}/${DBPATH} ${WRKSRC}/var/tmp ${WRKSRC}/lib
- @cd ${WRKSRC}/lib && ${LN} -sf libtermcap.so.2.0.8 libtermcap.so.2
- @${RPM} --initdb --root ${WRKSRC} --dbpath ${DBPATH}
-#
-# Make sure we have a /dev/null in the chrooted environment.
- @${MKDIR} ${WRKSRC}/dev
- @${RM} -f ${WRKSRC}/dev/null
- @mknod ${WRKSRC}/dev/null c 2 2
- @${CHMOD} 666 ${WRKSRC}/dev/null
-#
-# Install all packages. Ignore dependencies just like the Red Hat installer.
-# Also, set the ELF fallback brand to Linux, so that we don't have to do
-# anything special to run staticly linked binaries.
- @/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${LINUX_ELF}
- @for R in ${UPD_SET1} ${DISTFILES} ${UPD_SET2}; do \
- ${ECHO} $$R; \
- ${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
- done
- @for F in ${BRAND_FILES}; do \
- brandelf -t Linux ${WRKSRC}/$$F; \
- done
- @/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${PREVIOUS_ELF}
-#
-# Install yp.conf as a hint to NIS users and make sure there's a
-# mtab in etc, albeit an empty one. This is needed in a couple of
-# cases. Most notably staroffice6.
-#
- ${INSTALL} ${COPY} -m 644 ${FILESDIR}/yp.conf ${WRKSRC}/etc
- ${TOUCH} ${WRKSRC}/etc/mtab
-#
-# Finish
-#
- @for D in ${REMOVE_DIRS}; do \
- ${RM} -rf ${WRKSRC}/$$D; \
- done
- @for F in ${REMOVE_FILES}; do \
- ${RM} -f ${WRKSRC}/$$F; \
- done
- @${LN} -sf /var/tmp ${WRKSRC}/usr/tmp
-
-pre-install:
- ${RM} -f ${PLIST}
- cd ${WRKSRC} && ${FIND} -s . -type f -o -type l | \
- ${CUT} -c3-999 >> ${PLIST} \
- && ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
-
-do-install:
- cd ${WRKSRC} && ${FIND} * | cpio -dlmp ${PREFIX}
- ${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
-
-post-install:
- @${ECHO} ''
- @fmt ${PKGMESSAGE}
- @${ECHO} ''
-
-.include <bsd.port.post.mk>
diff --git a/emulators/linux_base-rh-9/distinfo.i386 b/emulators/linux_base-rh-9/distinfo.i386
deleted file mode 100644
index 5f3866f226fa..000000000000
--- a/emulators/linux_base-rh-9/distinfo.i386
+++ /dev/null
@@ -1,34 +0,0 @@
-$FreeBSD$
-MD5 (rpm/i386/8.0/basesystem-8.0-1.noarch.rpm) = d66629eeffdc61de69395be8c43f4f7d
-MD5 (rpm/i386/8.0/bash-2.05b-5.i386.rpm) = ffea80578086373dda7d7e98ec42b294
-MD5 (rpm/i386/8.0/bzip2-1.0.2-5.i386.rpm) = 05674cb719aef022396581808669105d
-MD5 (rpm/i386/8.0/bzip2-libs-1.0.2-5.i386.rpm) = a96d125105d1eb56c0b71bc699b84288
-MD5 (rpm/i386/8.0/compat-db-3.3.11-2.i386.rpm) = c8ec0b5bce196a8f6dcc2b559d5fd625
-MD5 (rpm/i386/8.0/compat-libstdc++-7.3-2.96.110.i386.rpm) = 298aaa504398f2b7298f805e4f751afe
-MD5 (rpm/i386/8.0/db4-4.0.14-14.i386.rpm) = 2b31e1ac5ccc23f0dbd37e299ed91661
-MD5 (rpm/i386/8.0/filesystem-2.1.6-5.noarch.rpm) = f9f4c4e31668216e5cd98c05c3e4751f
-MD5 (rpm/i386/8.0/fileutils-4.1.9-11.i386.rpm) = 7d6f449488f8e7360c74101c20e4052c
-MD5 (rpm/i386/8.0/freetype-2.1.2-7.i386.rpm) = 1d11846f80741cf629908fff77565c1d
-MD5 (rpm/i386/8.0/gdbm-1.8.0-18.i386.rpm) = 247aa33363cdf4ac0c01a17893221ac7
-MD5 (rpm/i386/8.0/glib-1.2.10-8.i386.rpm) = cad221120dd2aa32dbbf274f694e982b
-MD5 (rpm/i386/8.0/glibc-2.3.2-4.80.6.i386.rpm) = 57aeffb616ba40a37e97c83a61f2580b
-MD5 (rpm/i386/8.0/glibc-common-2.3.2-4.80.6.i386.rpm) = 376eb93ae98d0549341a72cc30d136f1
-MD5 (rpm/i386/8.0/grep-2.5.1-4.i386.rpm) = d47cb3261cca975b1b177acec30d1b88
-MD5 (rpm/i386/8.0/info-4.2-5.i386.rpm) = d273ca4e7d607f0df77179e6493211fb
-MD5 (rpm/i386/8.0/libacl-2.0.11-2.i386.rpm) = 4c925ae8eb502c2102e7fcee40e78b3e
-MD5 (rpm/i386/8.0/libattr-2.0.8-3.i386.rpm) = 6e96282afe6ebaf2caf2d0022f5e7063
-MD5 (rpm/i386/8.0/libelf-0.8.2-2.i386.rpm) = 7a4ea791d46ca45f9e398a9732216c17
-MD5 (rpm/i386/8.0/libgcc-3.2-7.i386.rpm) = db9ca2ea377a30e7a7ab0c95fb538b00
-MD5 (rpm/i386/8.0/libstdc++-3.2-7.i386.rpm) = 1593270df028b4225818f4cb08cb0b40
-MD5 (rpm/i386/8.0/libtermcap-2.0.8-31.i386.rpm) = 64426510f27078a3f35a3a02ee4da7fc
-MD5 (rpm/i386/8.0/ncurses-5.2-28.i386.rpm) = 1240c14ba8fe20b5e9cc8c3591f0a533
-MD5 (rpm/i386/8.0/popt-1.7-1.06.i386.rpm) = 158c59ec88320586ce0100b2eec140ab
-MD5 (rpm/i386/8.0/readline-4.3-3.i386.rpm) = 6a41eba752dee08222b99cce58552fea
-MD5 (rpm/i386/8.0/redhat-release-8.0-8.noarch.rpm) = 7cbf42500f3f91c7df1e1495b5f1ee1d
-MD5 (rpm/i386/8.0/rpm-4.1-1.06.i386.rpm) = fc0f9967e7dd7b4bf3f4e1e25d5047aa
-MD5 (rpm/i386/8.0/setserial-2.17-9.i386.rpm) = 132160b9a4718d86eb14b86f780de3a5
-MD5 (rpm/i386/8.0/setup-2.5.20-1.noarch.rpm) = 94168e9cd5d2c6601167d55e50e70bc0
-MD5 (rpm/i386/8.0/sh-utils-2.0.12-3.i386.rpm) = 1b9d53f5a86d2dcb1ed7ce2647274476
-MD5 (rpm/i386/8.0/slang-1.4.5-11.i386.rpm) = eb551fe40c244f750c089d6d450cd0e7
-MD5 (rpm/i386/8.0/termcap-11.0.1-13.noarch.rpm) = 80354e467c784ad660edcd9ec9eb0148
-MD5 (rpm/i386/8.0/zlib-1.1.4-8.8x.i386.rpm) = fb1db2a01b5366cb40f98fda4507024e
diff --git a/emulators/linux_base-rh-9/files/yp.conf b/emulators/linux_base-rh-9/files/yp.conf
deleted file mode 100644
index 64faed4de3fa..000000000000
--- a/emulators/linux_base-rh-9/files/yp.conf
+++ /dev/null
@@ -1,15 +0,0 @@
-# sample yp.conf file
-#
-# Legal entries are:
-#
-# domainname <domain> Override the default YP domain
-# (If not set uses the one from
-# the getdomainname() syscall)
-#
-# ypserver <grape> [<domain>] Define which host to contact
-# for YP service. If the <domain>
-# argument is included then this
-# host service the specified YP
-# domain.
-#domainname my.domain
-#ypserver localhost
diff --git a/emulators/linux_base-rh-9/pkg-descr b/emulators/linux_base-rh-9/pkg-descr
deleted file mode 100644
index 3e241fba4ce1..000000000000
--- a/emulators/linux_base-rh-9/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-This port contains packages from a near-minimal installation of Red Hat Linux
-8.0. These packages, in conjunction with the linux module, form the basis of
-the Linux compatibility environment.
-
-This port is only available for the i386 architecture. If you use an Alpha
-computer, please install the linux_base port instead of this one.
-
-If you want to run X11 applications, install the x11/linux-XFree86-libs port.
diff --git a/emulators/linux_base-rh-9/pkg-install b/emulators/linux_base-rh-9/pkg-install
deleted file mode 100644
index 2d569a739289..000000000000
--- a/emulators/linux_base-rh-9/pkg-install
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-# an installation script for linux_base
-
-case "$2" in
-PRE-INSTALL)
- if [ -z "`kldstat -v | grep -E 'linux(aout|elf)'`" ]; then
- echo 'Linux mode is not enabled.'
- echo 'Loading linux kernel module now...'
- if ! kldload linux; then
- echo 'The linux kernel module could not be loaded.'
- echo 'Please enable linux mode manually and retry.'
- exit 1
- fi
- fi
- if [ -n "`mount | grep -w ^linprocfs`" ]; then
- echo 'Un-mounting linprocfs...'
- umount linprocfs
- fi
- ;;
-POST-INSTALL)
- if [ -n "`grep -w ^linprocfs /etc/fstab`" ]; then
- echo 'Re-mounting linprocfs...'
- mount linprocfs
- fi
- ;;
-DEINSTALL)
- if [ -n "`mount | grep -w ^linprocfs`" ]; then
- echo 'Un-mounting linprocfs...'
- umount linprocfs
- fi
- ;;
-esac
-
-exit 0
diff --git a/emulators/linux_base-rh-9/pkg-message b/emulators/linux_base-rh-9/pkg-message
deleted file mode 100644
index b7d8d197ca8f..000000000000
--- a/emulators/linux_base-rh-9/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-This software is based in part on the work of the FreeType Team.
-See <URL:http://www.freetype.org/>.
-
-Installation of the Linux base system is
-finished. The Linux kernel mode, which
-must be enabled for Linux binaries to run,
-is now enabled. Linux mode can be enabled
-permanently with the linux_enable variable
-of rc.conf(5).
-
-When using NIS, don't forget to edit
-yp.conf in /compat/linux/etc.