aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-suse-9.2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux_base-suse-9.2/Makefile')
-rw-r--r--emulators/linux_base-suse-9.2/Makefile137
1 files changed, 65 insertions, 72 deletions
diff --git a/emulators/linux_base-suse-9.2/Makefile b/emulators/linux_base-suse-9.2/Makefile
index 0e39182eae57..2d37552db061 100644
--- a/emulators/linux_base-suse-9.2/Makefile
+++ b/emulators/linux_base-suse-9.2/Makefile
@@ -1,72 +1,67 @@
-# New ports collection makefile for: linux_base-suse-9.1
-# Date created: 2004-12-19
+# New ports collection makefile for: linux_base-suse-9.2
+# Date created: 2005-01-11
# Whom: trevor
# based on ports/emulators/linux_base by Marcel Moolenaar and others
#
# $FreeBSD$
+# $FreeBSD$
#
PORTNAME= linux_base-suse
-PORTVERSION= 9.1
+PORTVERSION= 9.2
CATEGORIES= emulators linux
-MASTER_SITES= ${MASTER_SITE_SUSE}
-MASTER_SITE_SUBDIR= i386/9.1/suse/i586
-DISTFILES= suse-release-9.1-0.i586.rpm \
- glibc-locale-2.3.3-98.i586.rpm \
- glibc-2.3.3-98.i586.rpm \
- filesystem-9.1-0.i586.rpm \
- libattr-2.4.12-56.i586.rpm \
- db-4.2.52-85.i586.rpm \
- gdbm-1.8.3-225.i586.rpm \
- glib-1.2.10-586.i586.rpm \
- bash-2.05b-305.i586.rpm \
- ncurses-5.4-59.i586.rpm \
- readline-4.3-306.i586.rpm \
- zlib-1.2.1-70.i586.rpm \
- info-4.6-61.i586.rpm \
- grep-2.5.1-416.i586.rpm \
- desktop-file-utils-0.3.0.cvs20030807-221.i586.rpm \
- coreutils-5.2.1-23.i586.rpm \
- popt-1.7-176.i586.rpm \
- insserv-1.00.2-85.i586.rpm \
- setserial-2.17-577.i586.rpm \
- libstdc++-3.3.3-41.i586.rpm \
- slang-1.4.9-121.i586.rpm \
- bzip2-1.0.2-344.i586.rpm \
- libacl-2.2.21-54.i586.rpm \
- libselinux-1.8-16.i586.rpm \
- rpm-4.1.1-177.i586.rpm \
- libgcc-3.3.3-41.i586.rpm \
- termcap-2.0.8-876.i586.rpm \
- freetype2-2.1.7-53.i586.rpm
+MASTER_SITES= ${MASTER_SITE_SUSE} ${MASTER_SITE_SUSE:S/$/:update/}
+MASTER_SITE_SUBDIR= i386/9.2/suse/i586 i386/update/9.2/rpm/i586/:update
+DISTFILES= \
+ suse-release-9.2-3.1.i586.rpm \
+ glibc-locale-2.3.3-118.i586.rpm \
+ glibc-2.3.3-118.i586.rpm \
+ filesystem-9.2-2.1.i586.rpm \
+ libattr-2.4.16-2.i586.rpm \
+ db-4.2.52-90.i586.rpm \
+ compat-gdbm-1.8.0-4.i586.rpm \
+ glib-1.2.10-589.i586.rpm \
+ bash-3.0-8.2.i586.rpm:update \
+ ncurses-5.4-65.i586.rpm \
+ readline-5.0-1.2.i586.rpm:update \
+ zlib-1.2.1-74.i586.rpm \
+ bzip2-1.0.2-347.i586.rpm \
+ libzio-0.1-4.i586.rpm \
+ info-4.7-6.i586.rpm \
+ grep-2.5.1-431.i586.rpm \
+ desktop-file-utils-0.7-2.1.i586.rpm \
+ coreutils-5.2.1-32.i586.rpm \
+ popt-1.7-190.i586.rpm \
+ insserv-1.00.5-6.2.i586.rpm \
+ setserial-2.17-579.i586.rpm \
+ libstdc++-3.3.4-11.i586.rpm \
+ slang-1.4.9-123.i586.rpm \
+ libacl-2.2.25-2.i586.rpm \
+ libselinux-1.16-3.i586.rpm \
+ rpm-4.1.1-191.i586.rpm \
+ libgcc-3.3.4-11.i586.rpm \
+ termcap-2.0.8-878.i586.rpm
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= Basic packages for Linux mode from SUSE 9.1/i386
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= Basic packages for Linux mode from SUSE 9.2/i386
EXTRACT_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-CONFLICTS= linux_base-6* linux_base-7* linux_base-debian* \
- linux_base-gentoo* linux_base-rh-9*
+CONFLICTS= linux_base-6* linux_base-7* linux_base-debian* \
+ linux_base-gentoo* linux_base-rh* linux_base-suse-9.1*
-RESTRICTED= "binaries under GNU GPL without accompanying source"
-ONLY_FOR_ARCHS= i386
-DIST_SUBDIR= rpm/${MACHINE_ARCH}/suse
+RESTRICTED= "binaries under GNU GPL: http://www.gnu.org/licenses/gpl.txt"
+ONLY_FOR_ARCHS= amd64 i386
+DIST_SUBDIR= rpm/i386/suse/9.2
PREFIX= ${LINUXBASE}
-NO_BUILD= yes
NO_FILTER_SHLIBS= yes
NO_MTREE= yes
-PLIST= ${WRKDIR}/pkg-plist
+PLIST= ${WRKDIR}/plist
-.ifdef USE_LINUX
-.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
+# Avoid cyclic dependency.
+.undef USE_LINUX
.include <bsd.port.pre.mk>
-DBPATH= /var/lib/rpm
-RPM= LC_ALL=C rpm
-RPMFLAGS= --root ${WRKSRC} --dbpath ${DBPATH} --nodeps \
- --replacepkgs --ignoreos --ignorearch
-RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
REMOVE_DIRS= boot dev home initrd root tmp var/tmp usr/local usr/tmp
REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
etc/motd etc/passwd etc/printcap etc/services \
@@ -86,32 +81,27 @@ do-extract:
#
# Handle the loading of the linux loadable kernel module if required.
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
- @${MKDIR} ${WRKSRC}/${DBPATH} ${WRKSRC}/var/tmp ${WRKSRC}/lib
+ @${MKDIR} ${WRKSRC}/var/lib/rpm ${WRKSRC}/var/tmp ${WRKSRC}/lib
@cd ${WRKSRC}/lib && ${LN} -sf libtermcap.so.2.0.8 libtermcap.so.2
- @${RPM} --initdb --root ${WRKSRC} --dbpath ${DBPATH}
-#
-# Make sure we have a /dev/null in the chrooted environment.
- @${MKDIR} ${WRKSRC}/dev
- @${RM} -f ${WRKSRC}/dev/null
- @mknod ${WRKSRC}/dev/null c 2 2
- @${CHMOD} 666 ${WRKSRC}/dev/null
+ LC_ALL=C rpm --initdb --root ${WRKSRC} --dbpath /var/lib/rpm
#
# Install all packages. Ignore dependencies just like the Red Hat installer.
# Also, set the ELF fallback brand to Linux, so that we don't have to do
-# anything special to run staticly linked binaries.
+# anything special to run statically linked binaries.
@/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${LINUX_ELF}
- @for R in ${DISTFILES:S/:new//}; do \
- ${ECHO} $$R; \
- ${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
+ @for ii in ${DISTFILES:S/:update//}; do \
+ LC_ALL=C rpm -U --root ${WRKSRC} --dbpath /var/lib/rpm \
+ --nodeps --replacepkgs --ignoreos --ignorearch \
+ ${DISTDIR}/${DIST_SUBDIR}/$$ii; \
done
@for F in ${BRAND_FILES}; do \
- brandelf -t Linux ${WRKSRC}/$$F; \
+ ${BRANDELF} -t Linux ${WRKSRC}/$$F; \
done
@/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${PREVIOUS_ELF}
#
-# Install yp.conf as a hint to NIS users and make sure there's a
+# Install yp.conf as a hint to NIS users and make sure there's an
# mtab in etc, albeit an empty one. This is needed in a couple of
-# cases. Most notably staroffice6.
+# cases, notably staroffice6.
#
${INSTALL} ${COPY} -m 644 ${FILESDIR}/yp.conf ${WRKSRC}/etc
${TOUCH} ${WRKSRC}/etc/mtab ${WRKSRC}/etc/host.conf
@@ -126,19 +116,22 @@ do-extract:
done
@${LN} -sf /var/tmp ${WRKSRC}/usr/tmp
-pre-install:
- ${RM} -f ${PLIST}
- cd ${WRKSRC} && ${FIND} -s . -type f -o -type l | \
- ${CUT} -c3-999 >> ${PLIST} \
+do-build:
+#
+# Generate packing list.
+ cd ${WRKSRC} && ${FIND} -s * -type f -o -type l > ${PLIST} \
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
do-install:
+#
+# Try to hard-link the contents of the work directory to the installation
+# directory. If hard-linking is possible (installing to the same mount point),
+# no disk space is consumed in the installation step. The fallback is to copy,
+# and cpio is noisy in this case.
cd ${WRKSRC} && ${FIND} * | ${CPIO} -dlmp ${PREFIX}
${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
post-install:
- @${ECHO} ''
- @fmt ${PKGMESSAGE}
- @${ECHO} ''
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>