aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-suse-9.2
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux_base-suse-9.2')
-rw-r--r--emulators/linux_base-suse-9.2/Makefile144
-rw-r--r--emulators/linux_base-suse-9.2/distinfo56
-rw-r--r--emulators/linux_base-suse-9.2/files/yp.conf15
-rw-r--r--emulators/linux_base-suse-9.2/pkg-descr9
-rw-r--r--emulators/linux_base-suse-9.2/pkg-install46
-rw-r--r--emulators/linux_base-suse-9.2/pkg-message12
6 files changed, 0 insertions, 282 deletions
diff --git a/emulators/linux_base-suse-9.2/Makefile b/emulators/linux_base-suse-9.2/Makefile
deleted file mode 100644
index 0e39182eae57..000000000000
--- a/emulators/linux_base-suse-9.2/Makefile
+++ /dev/null
@@ -1,144 +0,0 @@
-# New ports collection makefile for: linux_base-suse-9.1
-# Date created: 2004-12-19
-# Whom: trevor
-# based on ports/emulators/linux_base by Marcel Moolenaar and others
-#
-# $FreeBSD$
-#
-
-PORTNAME= linux_base-suse
-PORTVERSION= 9.1
-CATEGORIES= emulators linux
-MASTER_SITES= ${MASTER_SITE_SUSE}
-MASTER_SITE_SUBDIR= i386/9.1/suse/i586
-DISTFILES= suse-release-9.1-0.i586.rpm \
- glibc-locale-2.3.3-98.i586.rpm \
- glibc-2.3.3-98.i586.rpm \
- filesystem-9.1-0.i586.rpm \
- libattr-2.4.12-56.i586.rpm \
- db-4.2.52-85.i586.rpm \
- gdbm-1.8.3-225.i586.rpm \
- glib-1.2.10-586.i586.rpm \
- bash-2.05b-305.i586.rpm \
- ncurses-5.4-59.i586.rpm \
- readline-4.3-306.i586.rpm \
- zlib-1.2.1-70.i586.rpm \
- info-4.6-61.i586.rpm \
- grep-2.5.1-416.i586.rpm \
- desktop-file-utils-0.3.0.cvs20030807-221.i586.rpm \
- coreutils-5.2.1-23.i586.rpm \
- popt-1.7-176.i586.rpm \
- insserv-1.00.2-85.i586.rpm \
- setserial-2.17-577.i586.rpm \
- libstdc++-3.3.3-41.i586.rpm \
- slang-1.4.9-121.i586.rpm \
- bzip2-1.0.2-344.i586.rpm \
- libacl-2.2.21-54.i586.rpm \
- libselinux-1.8-16.i586.rpm \
- rpm-4.1.1-177.i586.rpm \
- libgcc-3.3.3-41.i586.rpm \
- termcap-2.0.8-876.i586.rpm \
- freetype2-2.1.7-53.i586.rpm
-
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= Basic packages for Linux mode from SUSE 9.1/i386
-
-EXTRACT_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-
-CONFLICTS= linux_base-6* linux_base-7* linux_base-debian* \
- linux_base-gentoo* linux_base-rh-9*
-
-RESTRICTED= "binaries under GNU GPL without accompanying source"
-ONLY_FOR_ARCHS= i386
-DIST_SUBDIR= rpm/${MACHINE_ARCH}/suse
-PREFIX= ${LINUXBASE}
-NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
-NO_MTREE= yes
-PLIST= ${WRKDIR}/pkg-plist
-
-.ifdef USE_LINUX
-.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
-
-.include <bsd.port.pre.mk>
-DBPATH= /var/lib/rpm
-RPM= LC_ALL=C rpm
-RPMFLAGS= --root ${WRKSRC} --dbpath ${DBPATH} --nodeps \
- --replacepkgs --ignoreos --ignorearch
-RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
-REMOVE_DIRS= boot dev home initrd root tmp var/tmp usr/local usr/tmp
-REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/localtime \
- etc/motd etc/passwd etc/printcap etc/services \
- etc/protocols
-BRAND_FILES= bin/rpm sbin/ldconfig
-
-.if (${ARCH} == "amd64")
-LATEST_LINK:= ${LATEST_LINK:C/linux/linux32/}
-FALLBACK_ELF_MIB= kern.elf32.fallback_brand
-.else
-FALLBACK_ELF_MIB= kern.fallback_elf_brand
-.endif
-LINUX_ELF= 3
-PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
-
-do-extract:
-#
-# Handle the loading of the linux loadable kernel module if required.
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
- @${MKDIR} ${WRKSRC}/${DBPATH} ${WRKSRC}/var/tmp ${WRKSRC}/lib
- @cd ${WRKSRC}/lib && ${LN} -sf libtermcap.so.2.0.8 libtermcap.so.2
- @${RPM} --initdb --root ${WRKSRC} --dbpath ${DBPATH}
-#
-# Make sure we have a /dev/null in the chrooted environment.
- @${MKDIR} ${WRKSRC}/dev
- @${RM} -f ${WRKSRC}/dev/null
- @mknod ${WRKSRC}/dev/null c 2 2
- @${CHMOD} 666 ${WRKSRC}/dev/null
-#
-# Install all packages. Ignore dependencies just like the Red Hat installer.
-# Also, set the ELF fallback brand to Linux, so that we don't have to do
-# anything special to run staticly linked binaries.
- @/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${LINUX_ELF}
- @for R in ${DISTFILES:S/:new//}; do \
- ${ECHO} $$R; \
- ${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
- done
- @for F in ${BRAND_FILES}; do \
- brandelf -t Linux ${WRKSRC}/$$F; \
- done
- @/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${PREVIOUS_ELF}
-#
-# Install yp.conf as a hint to NIS users and make sure there's a
-# mtab in etc, albeit an empty one. This is needed in a couple of
-# cases. Most notably staroffice6.
-#
- ${INSTALL} ${COPY} -m 644 ${FILESDIR}/yp.conf ${WRKSRC}/etc
- ${TOUCH} ${WRKSRC}/etc/mtab ${WRKSRC}/etc/host.conf
-#
-# Finish
-#
- @for D in ${REMOVE_DIRS}; do \
- ${RM} -rf ${WRKSRC}/$$D; \
- done
- @for F in ${REMOVE_FILES}; do \
- ${RM} -f ${WRKSRC}/$$F; \
- done
- @${LN} -sf /var/tmp ${WRKSRC}/usr/tmp
-
-pre-install:
- ${RM} -f ${PLIST}
- cd ${WRKSRC} && ${FIND} -s . -type f -o -type l | \
- ${CUT} -c3-999 >> ${PLIST} \
- && ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
-
-do-install:
- cd ${WRKSRC} && ${FIND} * | ${CPIO} -dlmp ${PREFIX}
- ${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
-
-post-install:
- @${ECHO} ''
- @fmt ${PKGMESSAGE}
- @${ECHO} ''
-
-.include <bsd.port.post.mk>
diff --git a/emulators/linux_base-suse-9.2/distinfo b/emulators/linux_base-suse-9.2/distinfo
deleted file mode 100644
index c3165de1aedb..000000000000
--- a/emulators/linux_base-suse-9.2/distinfo
+++ /dev/null
@@ -1,56 +0,0 @@
-MD5 (rpm/i386/suse/suse-release-9.1-0.i586.rpm) = 64c7f2a65b24be66745ab2ee1b5e89b4
-SIZE (rpm/i386/suse/suse-release-9.1-0.i586.rpm) = 3030
-MD5 (rpm/i386/suse/glibc-locale-2.3.3-98.i586.rpm) = 0dd987d1c41cb0c24ae8f1437a4cb5fe
-SIZE (rpm/i386/suse/glibc-locale-2.3.3-98.i586.rpm) = 10393732
-MD5 (rpm/i386/suse/glibc-2.3.3-98.i586.rpm) = 15ed4f06fa275c2fe708a65ded7e8efe
-SIZE (rpm/i386/suse/glibc-2.3.3-98.i586.rpm) = 1455673
-MD5 (rpm/i386/suse/filesystem-9.1-0.i586.rpm) = cb5c967c87558b9c70083764a8336e59
-SIZE (rpm/i386/suse/filesystem-9.1-0.i586.rpm) = 41238
-MD5 (rpm/i386/suse/libattr-2.4.12-56.i586.rpm) = af5c308fa2a126706d2ea8c026868ef4
-SIZE (rpm/i386/suse/libattr-2.4.12-56.i586.rpm) = 11086
-MD5 (rpm/i386/suse/db-4.2.52-85.i586.rpm) = 9a644221e434ab8b67260391bd7fbba1
-SIZE (rpm/i386/suse/db-4.2.52-85.i586.rpm) = 775965
-MD5 (rpm/i386/suse/gdbm-1.8.3-225.i586.rpm) = 9520e2d862887c650033a8a69ff3bad9
-SIZE (rpm/i386/suse/gdbm-1.8.3-225.i586.rpm) = 27027
-MD5 (rpm/i386/suse/glib-1.2.10-586.i586.rpm) = f8545f68e60d7bf27f0f3b988b27f276
-SIZE (rpm/i386/suse/glib-1.2.10-586.i586.rpm) = 124852
-MD5 (rpm/i386/suse/bash-2.05b-305.i586.rpm) = 21c636daa38c1406d7add2a69416578a
-SIZE (rpm/i386/suse/bash-2.05b-305.i586.rpm) = 636675
-MD5 (rpm/i386/suse/ncurses-5.4-59.i586.rpm) = 5d3b5ddb2508853af9f738968696b257
-SIZE (rpm/i386/suse/ncurses-5.4-59.i586.rpm) = 790419
-MD5 (rpm/i386/suse/readline-4.3-306.i586.rpm) = 26c47a9f0472d0d946cd5c495c790dc5
-SIZE (rpm/i386/suse/readline-4.3-306.i586.rpm) = 151357
-MD5 (rpm/i386/suse/zlib-1.2.1-70.i586.rpm) = 021fa0b41c54e916cd1d1d4f96d37c2c
-SIZE (rpm/i386/suse/zlib-1.2.1-70.i586.rpm) = 63453
-MD5 (rpm/i386/suse/info-4.6-61.i586.rpm) = f205c1491ce440410aa47048a608c0bb
-SIZE (rpm/i386/suse/info-4.6-61.i586.rpm) = 144064
-MD5 (rpm/i386/suse/grep-2.5.1-416.i586.rpm) = b7fb42f3915a67d8d26347e87fc81bc3
-SIZE (rpm/i386/suse/grep-2.5.1-416.i586.rpm) = 169601
-MD5 (rpm/i386/suse/desktop-file-utils-0.3.0.cvs20030807-221.i586.rpm) = 85360525dfad7c3e806dda689dbe3709
-SIZE (rpm/i386/suse/desktop-file-utils-0.3.0.cvs20030807-221.i586.rpm) = 148110
-MD5 (rpm/i386/suse/coreutils-5.2.1-23.i586.rpm) = 2408d42377ed371ac7d322d37994e155
-SIZE (rpm/i386/suse/coreutils-5.2.1-23.i586.rpm) = 1982252
-MD5 (rpm/i386/suse/popt-1.7-176.i586.rpm) = 7f675630429ba0c800569ac99e3a9ca4
-SIZE (rpm/i386/suse/popt-1.7-176.i586.rpm) = 52024
-MD5 (rpm/i386/suse/insserv-1.00.2-85.i586.rpm) = c051fb7190d644c4eeb51f5db5537c8f
-SIZE (rpm/i386/suse/insserv-1.00.2-85.i586.rpm) = 23065
-MD5 (rpm/i386/suse/setserial-2.17-577.i586.rpm) = 47b759eeb2ef816cd1d9384943b3bd32
-SIZE (rpm/i386/suse/setserial-2.17-577.i586.rpm) = 23898
-MD5 (rpm/i386/suse/libstdc++-3.3.3-41.i586.rpm) = c89536486be1657bcd3f941deb5a265b
-SIZE (rpm/i386/suse/libstdc++-3.3.3-41.i586.rpm) = 301785
-MD5 (rpm/i386/suse/slang-1.4.9-121.i586.rpm) = 99279709a3dedfbc38859878f18cb97e
-SIZE (rpm/i386/suse/slang-1.4.9-121.i586.rpm) = 233659
-MD5 (rpm/i386/suse/bzip2-1.0.2-344.i586.rpm) = 5a1b566f07e9cc9e3f43647f446a57d5
-SIZE (rpm/i386/suse/bzip2-1.0.2-344.i586.rpm) = 221961
-MD5 (rpm/i386/suse/libacl-2.2.21-54.i586.rpm) = e07c7272a1b7fd2db1ec87f82c6dc4d3
-SIZE (rpm/i386/suse/libacl-2.2.21-54.i586.rpm) = 18239
-MD5 (rpm/i386/suse/libselinux-1.8-16.i586.rpm) = 89e848b1c6db7aa7801469131e6446a4
-SIZE (rpm/i386/suse/libselinux-1.8-16.i586.rpm) = 47298
-MD5 (rpm/i386/suse/rpm-4.1.1-177.i586.rpm) = 9850bf427d6bec63ac33d1bf6b9fb563
-SIZE (rpm/i386/suse/rpm-4.1.1-177.i586.rpm) = 2182035
-MD5 (rpm/i386/suse/libgcc-3.3.3-41.i586.rpm) = 89bb43e9f4ebcd61635cb2a1e9266f96
-SIZE (rpm/i386/suse/libgcc-3.3.3-41.i586.rpm) = 51314
-MD5 (rpm/i386/suse/termcap-2.0.8-876.i586.rpm) = 50ec2b05091222e358816b82dca8e0e2
-SIZE (rpm/i386/suse/termcap-2.0.8-876.i586.rpm) = 60887
-MD5 (rpm/i386/suse/freetype2-2.1.7-53.i586.rpm) = b253ef843317ab50f12054aaf4a89a49
-SIZE (rpm/i386/suse/freetype2-2.1.7-53.i586.rpm) = 503443
diff --git a/emulators/linux_base-suse-9.2/files/yp.conf b/emulators/linux_base-suse-9.2/files/yp.conf
deleted file mode 100644
index 64faed4de3fa..000000000000
--- a/emulators/linux_base-suse-9.2/files/yp.conf
+++ /dev/null
@@ -1,15 +0,0 @@
-# sample yp.conf file
-#
-# Legal entries are:
-#
-# domainname <domain> Override the default YP domain
-# (If not set uses the one from
-# the getdomainname() syscall)
-#
-# ypserver <grape> [<domain>] Define which host to contact
-# for YP service. If the <domain>
-# argument is included then this
-# host service the specified YP
-# domain.
-#domainname my.domain
-#ypserver localhost
diff --git a/emulators/linux_base-suse-9.2/pkg-descr b/emulators/linux_base-suse-9.2/pkg-descr
deleted file mode 100644
index 26b96e088f3e..000000000000
--- a/emulators/linux_base-suse-9.2/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-This port contains packages from a near-minimal installation of SUSE Linux
-9.1. These packages, in conjunction with the linux module, form the basis of
-the Linux compatibility environment.
-
-This port is only available for the i386 architecture. If you use an Alpha
-computer, please install the linux_base port instead of this one.
-
-If you want to run Linux X11 applications, please install the
-x11/linux-XFree86-libs port.
diff --git a/emulators/linux_base-suse-9.2/pkg-install b/emulators/linux_base-suse-9.2/pkg-install
deleted file mode 100644
index b4d717c72915..000000000000
--- a/emulators/linux_base-suse-9.2/pkg-install
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-# an installation script for linux_base
-
-case "$2" in
-PRE-INSTALL)
- if [ -z "`kldstat -v | grep -E 'linux(aout|elf)'`" ]; then
- echo 'Linux mode is not enabled.'
- echo 'Loading linux kernel module now...'
- if ! kldload linux; then
- echo 'The linux kernel module could not be loaded.'
- echo 'Please enable linux mode manually and retry.'
- exit 1
- fi
- fi
- if [ -n "`mount | grep -w ^linprocfs`" ]; then
- echo 'Un-mounting linprocfs...'
- umount linprocfs
- fi
- if [ -n "`mount | grep -w ^linproc`" ]; then
- echo 'Un-mounting linproc...'
- umount linproc
- fi
- ;;
-POST-INSTALL)
- if [ -n "`grep -w ^linprocfs /etc/fstab`" ]; then
- echo 'Re-mounting linprocfs...'
- mount linprocfs
- fi
- if [ -n "`grep -w ^linprocfs /etc/fstab`" ]; then
- echo 'Re-mounting linproc...'
- mount linproc
- fi
- ;;
-DEINSTALL)
- if [ -n "`mount | grep -w ^linprocfs`" ]; then
- echo 'Un-mounting linprocfs...'
- umount linprocfs
- fi
- if [ -n "`mount | grep -w ^linproc`" ]; then
- echo 'Un-mounting linproc...'
- umount linproc
- fi
- ;;
-esac
-
-exit 0
diff --git a/emulators/linux_base-suse-9.2/pkg-message b/emulators/linux_base-suse-9.2/pkg-message
deleted file mode 100644
index b7d8d197ca8f..000000000000
--- a/emulators/linux_base-suse-9.2/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-This software is based in part on the work of the FreeType Team.
-See <URL:http://www.freetype.org/>.
-
-Installation of the Linux base system is
-finished. The Linux kernel mode, which
-must be enabled for Linux binaries to run,
-is now enabled. Linux mode can be enabled
-permanently with the linux_enable variable
-of rc.conf(5).
-
-When using NIS, don't forget to edit
-yp.conf in /compat/linux/etc.