aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile46
-rw-r--r--emulators/mame/distinfo3
-rw-r--r--emulators/mame/files/patch-makefile87
-rw-r--r--emulators/mame/files/pkg-message.in13
-rw-r--r--emulators/mame/files/sdlmame.in16
-rw-r--r--emulators/mame/pkg-descr17
-rw-r--r--emulators/mame/pkg-plist30
7 files changed, 0 insertions, 212 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
deleted file mode 100644
index e533322fe0ee..000000000000
--- a/emulators/mame/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# New ports collection makefile for: sdlmame
-# Date created: 2007-01-10
-# Whom: alepulver
-#
-# $FreeBSD$
-#
-
-PORTNAME= sdlmame
-PORTVERSION= 0.120u2
-CATEGORIES= emulators
-MASTER_SITES= ftp://ftp.alepulver.com.ar/distfiles/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
-
-MAINTAINER= alepulver@FreeBSD.org
-COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
-
-USE_ZIP= yes
-USE_GL= yes
-USE_GMAKE= yes
-USE_SDL= sdl
-MAKEFILE= makefile
-
-SUB_FILES= ${PORTNAME} pkg-message
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/libexec/sdlmame
-.for f in obj/sdl/mame/build/file2str obj/sdl/mame/build/png2bdc mame testkeys romcmp \
- chdman jedutil makemeta regrep srcclean
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/sdlmame
-.endfor
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/ui.bdf ${DATADIR}
- ${CP} -R ${WRKSRC}/keymaps ${DATADIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
- ${CP} -R ${WRKSRC}/docs ${DOCSDIR}
-.endif
-
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-
-.include <bsd.port.mk>
diff --git a/emulators/mame/distinfo b/emulators/mame/distinfo
deleted file mode 100644
index 6cc3d1e63270..000000000000
--- a/emulators/mame/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (sdlmame0120u2.zip) = fc1ef0c683f15af8ab5bbd4c66081924
-SHA256 (sdlmame0120u2.zip) = c71dfcb8f37a700eb131c9eeff88c8c63609ecc55c7d28adcd7655d287120a29
-SIZE (sdlmame0120u2.zip) = 15955929
diff --git a/emulators/mame/files/patch-makefile b/emulators/mame/files/patch-makefile
deleted file mode 100644
index 590d221401d8..000000000000
--- a/emulators/mame/files/patch-makefile
+++ /dev/null
@@ -1,87 +0,0 @@
---- makefile.orig Sat Oct 20 16:33:18 2007
-+++ makefile Wed Nov 7 18:22:11 2007
-@@ -72,11 +72,13 @@
- # uncomment next line to include the internal profiler
- # PROFILER = 1
-
-+ifeq ($(ARCH),i386)
- # uncomment next line to use DRC MIPS3 engine
- X86_MIPS3_DRC = 1
-
- # uncomment next line to use DRC PowerPC engine
- X86_PPC_DRC = 1
-+endif
-
- # uncomment next line to use DRC Voodoo rasterizers
- # X86_VOODOO_DRC = 1
-@@ -99,7 +101,9 @@
- # CELL = 1
-
- # uncomment next line if you are building for a 64-bit target
--# PTR64 = 1
-+ifeq ($(ARCH),amd64)
-+PTR64 = 1
-+endif
-
- # uncomment next line to build expat as part of MAME build
- BUILD_EXPAT = 1
-@@ -168,8 +172,8 @@
-
- # compiler, linker and utilities
- AR = @ar
--CC = @gcc
--LD = @gcc
-+CC := @$(CC)
-+LD = @$(CC)
- MD = -mkdir$(EXE)
- RM = @rm -f
-
-@@ -248,7 +252,7 @@
- endif
-
- # fullname is prefix+name+suffix
--FULLNAME = $(PREFIX)$(NAME)$(SUFFIX)
-+FULLNAME = $(NAME)
-
- # add an EXE suffix to get the final emulator name
- EMULATOR = $(FULLNAME)$(EXE)
-@@ -318,7 +322,7 @@
- #-------------------------------------------------
-
- # we compile to C89 standard with GNU extensions
--CFLAGS = -std=gnu89
-+CFLAGS += -std=gnu89
-
- # add -g if we need symbols
- ifdef SYMBOLS
-@@ -352,11 +356,11 @@
- # if we are optimizing, include optimization options
- # and make all errors into warnings
- ifneq ($(OPTIMIZE),0)
--CFLAGS += $(ARCH) -fno-strict-aliasing
-+CFLAGS += -fno-strict-aliasing
-
- # only -Werror if not PTR64 and not DEBUG
- ifndef DEBUG
--CFLAGS += $(ARCH) -fno-strict-aliasing
-+CFLAGS += -fno-strict-aliasing
- endif # !DEBUG
- endif # neq OPTIMIZE
-
-@@ -376,6 +380,7 @@
- -I$(SRC)/lib/util \
- -I$(SRC)/osd \
- -I$(SRC)/osd/$(OSD) \
-+ -I$(LOCALBASE)/include
-
-
-
-@@ -385,7 +390,7 @@
-
- # LDFLAGS are used generally; LDFLAGSEMULATOR are additional
- # flags only used when linking the core emulator
--LDFLAGS =
-+LDFLAGS += -L$(LOCALBASE)/lib
- LDFLAGSEMULATOR =
-
- # add profiling information for the linker
diff --git a/emulators/mame/files/pkg-message.in b/emulators/mame/files/pkg-message.in
deleted file mode 100644
index 3290fa533a30..000000000000
--- a/emulators/mame/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
-==============================================================================
-
-SDLMAME has been installed.
-
-The MAME tools are installed in "%%PREFIX%%/libexec/sdlmame"
-to avoid conflicting with other MAME ports.
-
-A wrapper script "sdlmame" has been installed. It creates a "~/.sdlmame"
-directory mirroring the directory tree under "%%DATADIR%%"
-when you run it for the first time, and starts the program from there. So
-place all MAME files (e.g. ROMs, cheats, etc.) in "~/.sdlmame".
-
-==============================================================================
diff --git a/emulators/mame/files/sdlmame.in b/emulators/mame/files/sdlmame.in
deleted file mode 100644
index 099cea29a2f8..000000000000
--- a/emulators/mame/files/sdlmame.in
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-#
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.sdlmame, and create symlinks to the data files.
-#
-
-if [ ! -d ~/.sdlmame ]
-then
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.sdlmame/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.sdlmame/{} \; 2>/dev/null
-fi
-
-cd ~/.sdlmame || exit 1
-exec %%PREFIX%%/libexec/sdlmame/mame "$@"
diff --git a/emulators/mame/pkg-descr b/emulators/mame/pkg-descr
deleted file mode 100644
index b297a4b68fa9..000000000000
--- a/emulators/mame/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-SDLMAME is a port of the popular MAME. There are a few principles that guide
-it's development:
-
-1) Run on Linux/Unix, Mac OS X, and other SDL supported operating systems with
- as few changes as possible to the base Win32 code. This means we can track
- changes faster than larger more conventional ports such as MacMAME, and we
- also maintain what I call "Firefox compatibilty" where learning a major app
- only needs to be done once per application, and it then applies across many
- operating systems. If you can use the command-line Win32 MAME, you already
- know how to use SDLMAME on any platform you may encounter it on.
-
-2) MAME developers are important. By keeping quickly up to date, we make it
- easy for people on non-Windows platforms to make and submit changes to the
- core MAME code, and we offer native implementations of MAME's multi-window
- GUI debugger on both Linux/Unix and Mac OS X.
-
-WWW: http://rbelmont.mameworld.info/?page_id=163
diff --git a/emulators/mame/pkg-plist b/emulators/mame/pkg-plist
deleted file mode 100644
index d38051d262da..000000000000
--- a/emulators/mame/pkg-plist
+++ /dev/null
@@ -1,30 +0,0 @@
-bin/sdlmame
-libexec/sdlmame/chdman
-libexec/sdlmame/file2str
-libexec/sdlmame/jedutil
-libexec/sdlmame/makemeta
-libexec/sdlmame/mame
-libexec/sdlmame/png2bdc
-libexec/sdlmame/regrep
-libexec/sdlmame/romcmp
-libexec/sdlmame/srcclean
-libexec/sdlmame/testkeys
-%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
-%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
-%%PORTDOCS%%%%DOCSDIR%%/whatsnew_0120u2.txt
-%%DATADIR%%/keymaps/km-be.txt
-%%DATADIR%%/keymaps/km-ch.txt
-%%DATADIR%%/keymaps/km-de.txt
-%%DATADIR%%/keymaps/km-fr-OSX.txt
-%%DATADIR%%/keymaps/km-fr.txt
-%%DATADIR%%/ui.bdf
-@dirrm %%DATADIR%%/keymaps
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm libexec/sdlmame