aboutsummaryrefslogtreecommitdiff
path: root/emulators/mess/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/mess/Makefile')
-rw-r--r--emulators/mess/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index ed6455e8d98f..067948d6e8d1 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -24,6 +24,12 @@ MAKEFILE= makefile.sdl
SUB_FILES= ${PORTNAME} pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 && ${ARCH} == "amd64"
+BROKEN= does not compile
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/sdlmess
@@ -47,4 +53,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>