aboutsummaryrefslogtreecommitdiff
path: root/emulators/p-interp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/p-interp/Makefile')
-rw-r--r--emulators/p-interp/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/emulators/p-interp/Makefile b/emulators/p-interp/Makefile
index 39ba1e7f7c2f..6206f394738b 100644
--- a/emulators/p-interp/Makefile
+++ b/emulators/p-interp/Makefile
@@ -28,9 +28,14 @@ post-extract:
post-patch:
cd ${WRKDIR}/${DISTNAME} && ${MAKE} depend
+post-build:
+ cd ${WRKDIR}/${DISTNAME} && ${MAKE} work.svol
+
pre-install:
- ${MKDIR} ${PREFIX}/share/doc/p-interp
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${PREFIX}/share/doc/p-interp
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/COPYING ${PREFIX}/share/doc/p-interp
+ ${MKDIR} ${PREFIX}/share/p-interp
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${PREFIX}/share/p-interp
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/COPYING ${PREFIX}/share/p-interp
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/system.svol ${PREFIX}/share/p-interp
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/work.svol ${PREFIX}/share/p-interp
.include <bsd.port.post.mk>