aboutsummaryrefslogtreecommitdiff
path: root/emulators/pearpc
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 09b64ba0e55c..bb4d5708e89d 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -62,6 +62,11 @@ pre-everything::
@${ECHO_MSG} ""
.endif
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/src/system/posix/types.h
+.endif
+
post-configure:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile