aboutsummaryrefslogtreecommitdiff
path: root/emulators/psim-freebsd
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/psim-freebsd')
-rw-r--r--emulators/psim-freebsd/Makefile8
-rw-r--r--emulators/psim-freebsd/distinfo2
-rw-r--r--emulators/psim-freebsd/files/patch-bfd-archures.c38
-rw-r--r--emulators/psim-freebsd/files/patch-bfd-cpu-powerpc.c202
-rw-r--r--emulators/psim-freebsd/files/patch-emul_chirp.c15
-rw-r--r--emulators/psim-freebsd/files/patch-gen_idecode.c58
-rw-r--r--emulators/psim-freebsd/files/patch-gen_model.c11
-rw-r--r--emulators/psim-freebsd/files/patch-hw_tab.c16
-rw-r--r--emulators/psim-freebsd/files/patch-lf.c53
9 files changed, 4 insertions, 399 deletions
diff --git a/emulators/psim-freebsd/Makefile b/emulators/psim-freebsd/Makefile
index 31817646187c..f167b054d6a7 100644
--- a/emulators/psim-freebsd/Makefile
+++ b/emulators/psim-freebsd/Makefile
@@ -7,23 +7,21 @@
#
PORTNAME= psim-freebsd
-PORTVERSION= 5.2.1
+PORTVERSION= 6.0
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= gdb/releases
DISTNAME= gdb-${PORTVERSION}
MAINTAINER= mp@FreeBSD.org
-COMMENT= PowerPC simulator (PSIM) running in the GNU GDB 5
+COMMENT= PowerPC simulator (PSIM) running in the GNU GDB 6
+USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-psim --target=powerpc-freebsd-elf \
--program-suffix=psim
-pre-configure:
- @cd ${WRKSRC} ; ${RM} -rf dejagnu expect tcl texinfo
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${PREFIX}/bin/${PORTNAME}
${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
diff --git a/emulators/psim-freebsd/distinfo b/emulators/psim-freebsd/distinfo
index 3e216a1dc076..28d290638594 100644
--- a/emulators/psim-freebsd/distinfo
+++ b/emulators/psim-freebsd/distinfo
@@ -1 +1 @@
-MD5 (gdb-5.2.1.tar.gz) = e9766842f1bbc6c2353de1410d8c0de0
+MD5 (gdb-6.0.tar.bz2) = 14371795b7903b816a6a88c69cace168
diff --git a/emulators/psim-freebsd/files/patch-bfd-archures.c b/emulators/psim-freebsd/files/patch-bfd-archures.c
deleted file mode 100644
index 7740d1c83ce9..000000000000
--- a/emulators/psim-freebsd/files/patch-bfd-archures.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- bfd.orig/archures.c Sun May 12 10:57:05 2002
-+++ bfd/archures.c Sun May 12 10:58:13 2002
-@@ -288,7 +288,9 @@
- . const char *arch_name;
- . const char *printable_name;
- . unsigned int section_align_power;
--. {* True if this is the default machine for the architecture. *}
-+. {* True if this is the default machine for the architecture.
-+. The default arch should be the first entry for an arch so that
-+. all the entries for that arch can be accessed via <<next>>. *}
- . boolean the_default;
- . const struct bfd_arch_info * (*compatible)
- . PARAMS ((const struct bfd_arch_info *a,
-@@ -604,21 +606,9 @@
- enum bfd_architecture arch;
- unsigned long mach;
- {
-- const bfd_arch_info_type * const *app, *ap;
--
-- for (app = bfd_archures_list; *app != NULL; app++)
-- {
-- for (ap = *app; ap != NULL; ap = ap->next)
-- {
-- if (ap->arch == arch
-- && (ap->mach == mach
-- || (mach == 0 && ap->the_default)))
-- {
-- abfd->arch_info = ap;
-- return true;
-- }
-- }
-- }
-+ abfd->arch_info = bfd_lookup_arch (arch, mach);
-+ if (abfd->arch_info != NULL)
-+ return true;
-
- abfd->arch_info = &bfd_default_arch_struct;
- bfd_set_error (bfd_error_bad_value);
diff --git a/emulators/psim-freebsd/files/patch-bfd-cpu-powerpc.c b/emulators/psim-freebsd/files/patch-bfd-cpu-powerpc.c
deleted file mode 100644
index 1e4f96666d51..000000000000
--- a/emulators/psim-freebsd/files/patch-bfd-cpu-powerpc.c
+++ /dev/null
@@ -1,202 +0,0 @@
---- bfd.orig/cpu-powerpc.c Sun May 12 10:57:07 2002
-+++ bfd/cpu-powerpc.c Sun May 12 10:57:17 2002
-@@ -50,6 +50,65 @@
-
- const bfd_arch_info_type bfd_powerpc_archs[] =
- {
-+#if BFD_DEFAULT_TARGET_SIZE == 64 /* default arch must come first. */
-+ {
-+ 64, /* 64 bits in a word */
-+ 64, /* 64 bits in an address */
-+ 8, /* 8 bits in a byte */
-+ bfd_arch_powerpc,
-+ bfd_mach_ppc64,
-+ "powerpc",
-+ "powerpc:common64",
-+ 3,
-+ true, /* default for 64 bit target */
-+ powerpc_compatible,
-+ bfd_default_scan,
-+ &bfd_powerpc_archs[1]
-+ },
-+ {
-+ 32, /* 32 bits in a word */
-+ 32, /* 32 bits in an address */
-+ 8, /* 8 bits in a byte */
-+ bfd_arch_powerpc,
-+ bfd_mach_ppc, /* for the POWER/PowerPC common architecture */
-+ "powerpc",
-+ "powerpc:common",
-+ 3,
-+ false,
-+ powerpc_compatible,
-+ bfd_default_scan,
-+ &bfd_powerpc_archs[2],
-+ },
-+#else
-+ {
-+ 32, /* 32 bits in a word */
-+ 32, /* 32 bits in an address */
-+ 8, /* 8 bits in a byte */
-+ bfd_arch_powerpc,
-+ bfd_mach_ppc, /* for the POWER/PowerPC common architecture */
-+ "powerpc",
-+ "powerpc:common",
-+ 3,
-+ true, /* default for 32 bit target */
-+ powerpc_compatible,
-+ bfd_default_scan,
-+ &bfd_powerpc_archs[1],
-+ },
-+ {
-+ 64, /* 64 bits in a word */
-+ 64, /* 64 bits in an address */
-+ 8, /* 8 bits in a byte */
-+ bfd_arch_powerpc,
-+ bfd_mach_ppc64,
-+ "powerpc",
-+ "powerpc:common64",
-+ 3,
-+ false,
-+ powerpc_compatible,
-+ bfd_default_scan,
-+ &bfd_powerpc_archs[2]
-+ },
-+#endif
- {
- 32, /* 32 bits in a word */
- 32, /* 32 bits in an address */
-@@ -62,7 +121,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[1]
-+ &bfd_powerpc_archs[3]
- },
- {
- 32, /* 32 bits in a word */
-@@ -76,7 +135,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[2]
-+ &bfd_powerpc_archs[4]
- },
- {
- 32, /* 32 bits in a word */
-@@ -90,7 +149,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[3]
-+ &bfd_powerpc_archs[5]
- },
- {
- 32, /* 32 bits in a word */
-@@ -104,7 +163,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[4]
-+ &bfd_powerpc_archs[6]
- },
- {
- 32, /* 32 bits in a word */
-@@ -118,7 +177,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[5]
-+ &bfd_powerpc_archs[7]
- },
- {
- 64, /* 64 bits in a word */
-@@ -132,7 +191,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[6]
-+ &bfd_powerpc_archs[8]
- },
- {
- 64, /* 64 bits in a word */
-@@ -146,7 +205,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[7]
-+ &bfd_powerpc_archs[9]
- },
- {
- 64, /* 64 bits in a word */
-@@ -160,7 +219,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[8]
-+ &bfd_powerpc_archs[10]
- },
- {
- 64, /* 64 bits in a word */
-@@ -174,7 +233,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[9]
-+ &bfd_powerpc_archs[11]
- },
- {
- 64, /* 64 bits in a word */
-@@ -188,7 +247,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[10]
-+ &bfd_powerpc_archs[12]
- },
- {
- 32, /* 32 bits in a word */
-@@ -202,7 +261,7 @@
- false, /* not the default */
- powerpc_compatible,
- bfd_default_scan,
-- &bfd_powerpc_archs[11]
-+ &bfd_powerpc_archs[13]
- },
- {
- 32, /* 32 bits in a word */
-@@ -214,34 +273,6 @@
- "powerpc:MPC8XX",
- 3,
- false, /* not the default */
-- powerpc_compatible,
-- bfd_default_scan,
-- &bfd_powerpc_archs[12]
-- },
-- {
-- 64, /* 64 bits in a word */
-- 64, /* 64 bits in an address */
-- 8, /* 8 bits in a byte */
-- bfd_arch_powerpc,
-- bfd_mach_ppc64,
-- "powerpc",
-- "powerpc:common64",
-- 3,
-- BFD_DEFAULT_TARGET_SIZE == 64, /* default for 64 bit target */
-- powerpc_compatible,
-- bfd_default_scan,
-- &bfd_powerpc_archs[13]
-- },
-- {
-- 32, /* 32 bits in a word */
-- 32, /* 32 bits in an address */
-- 8, /* 8 bits in a byte */
-- bfd_arch_powerpc,
-- bfd_mach_ppc, /* for the POWER/PowerPC common architecture */
-- "powerpc",
-- "powerpc:common",
-- 3,
-- BFD_DEFAULT_TARGET_SIZE != 64, /* default for 32 bit target */
- powerpc_compatible,
- bfd_default_scan,
- 0
diff --git a/emulators/psim-freebsd/files/patch-emul_chirp.c b/emulators/psim-freebsd/files/patch-emul_chirp.c
deleted file mode 100644
index 06b6ec622ed8..000000000000
--- a/emulators/psim-freebsd/files/patch-emul_chirp.c
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -r -u sim/ppc/emul_chirp.c /local2/gcc/ppc/gdb+dejagnu-20011007/sim/ppc/emul_chirp.c
---- sim/ppc/emul_chirp.c Thu Apr 15 18:35:09 1999
-+++ /local2/gcc/ppc/gdb+dejagnu-20011007/sim/ppc/emul_chirp.c Sun Oct 7 16:16:57 2001
-@@ -1884,6 +1884,11 @@
- (unsigned long)chirp->sizeof_code);
- tree_parse(node, "./wimg %d", 0x7);
- tree_parse(node, "./pp %d", 0x2);
-+ node = tree_parse(root, "/cpus/cpu@0");
-+ tree_parse(node, "./translations 0x%lx 0x%lx 0x%0lx 0x%0lx 0x%0lx",
-+ (unsigned long)chirp->code_va, (unsigned long)chirp->sizeof_code,
-+ (unsigned long)chirp->code_ra, 0);
-+ node = tree_parse(root, "/chosen/mmu */cpus/cpu@0");
- }
-
- /* map in the program to run */
diff --git a/emulators/psim-freebsd/files/patch-gen_idecode.c b/emulators/psim-freebsd/files/patch-gen_idecode.c
deleted file mode 100644
index 8aac77126e62..000000000000
--- a/emulators/psim-freebsd/files/patch-gen_idecode.c
+++ /dev/null
@@ -1,58 +0,0 @@
---- sim/ppc/gen-idecode.c 2003/10/20 23:10:45 1.1
-+++ sim/ppc/gen-idecode.c 2003/10/20 23:16:21
-@@ -757,21 +757,21 @@
-
- if (!generate_smp) {
-
-- lf_putstr(file, "
--/* CASE 1: NO SMP (with or with out instruction cache).
--
-- In this case, we can take advantage of the fact that the current
-- instruction address does not need to be returned to the cpu object
-- after every execution of an instruction. Instead it only needs to
-- be saved when either A. the main loop exits or B. A cpu-halt or
-- cpu-restart call forces the loop to be re-enered. The later
-- functions always save the current cpu instruction address.
--
-- Two subcases also exist that with and that without an instruction
-- cache.
--
-- An additional complexity is the need to ensure that a 1:1 ratio
-- is maintained between the execution of an instruction and the
-+ lf_putstr(file, "\n\
-+/* CASE 1: NO SMP (with or with out instruction cache).\n\
-+\n\
-+ In this case, we can take advantage of the fact that the current\n\
-+ instruction address does not need to be returned to the cpu object\n\
-+ after every execution of an instruction. Instead it only needs to\n\
-+ be saved when either A. the main loop exits or B. A cpu-halt or\n\
-+ cpu-restart call forces the loop to be re-enered. The later\n\
-+ functions always save the current cpu instruction address.\n\
-+\n\
-+ Two subcases also exist that with and that without an instruction\n\
-+ cache.\n\
-+\n\
-+ An additional complexity is the need to ensure that a 1:1 ratio\n\
-+ is maintained between the execution of an instruction and the\n\
- incrementing of the simulation clock */");
-
- lf_putstr(file, "\n");
-@@ -867,12 +867,12 @@
-
- if (generate_smp) {
-
-- lf_putstr(file, "
--/* CASE 2: SMP (With or without ICACHE)
--
-- The complexity here comes from needing to correctly restart the
-- system when it is aborted. In particular if cpu0 requests a
-- restart, the next cpu is still cpu1. Cpu0 being restarted after
-+ lf_putstr(file, "\n\
-+/* CASE 2: SMP (With or without ICACHE)\n\
-+\n\
-+ The complexity here comes from needing to correctly restart the\n\
-+ system when it is aborted. In particular if cpu0 requests a\n\
-+ restart, the next cpu is still cpu1. Cpu0 being restarted after\n\
- all the other CPU's and the event queue have been processed */");
-
- lf_putstr(file, "\n");
diff --git a/emulators/psim-freebsd/files/patch-gen_model.c b/emulators/psim-freebsd/files/patch-gen_model.c
deleted file mode 100644
index bbb13f1fdbb9..000000000000
--- a/emulators/psim-freebsd/files/patch-gen_model.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- sim/ppc/gen-model.c 2003/10/20 23:38:14 1.1
-+++ sim/ppc/gen-model.c 2003/10/20 23:38:53
-@@ -377,7 +377,7 @@
- lf_printf(file, " }\n");
- lf_printf(file, " }\n");
- lf_printf(file, "\n");
-- lf_printf(file, " error(\"Unknown model '%%s', Models which are known are:%%s\n\",\n");
-+ lf_printf(file, " error(\"Unknown model '%%s', Models which are known are:%%s\\n\",\n");
- lf_printf(file, " name,\n");
- lf_printf(file, " \"");
- for(model_ptr = models; model_ptr; model_ptr = model_ptr->next) {
diff --git a/emulators/psim-freebsd/files/patch-hw_tab.c b/emulators/psim-freebsd/files/patch-hw_tab.c
deleted file mode 100644
index d188e6d87963..000000000000
--- a/emulators/psim-freebsd/files/patch-hw_tab.c
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -r -u sim/ppc/hw_htab.c /local2/gcc/ppc/gdb+dejagnu-20011007/sim/ppc/hw_htab.c
---- sim/ppc/hw_htab.c Thu Apr 15 18:35:09 1999
-+++ /local2/gcc/ppc/gdb+dejagnu-20011007/sim/ppc/hw_htab.c Sun Oct 7 16:16:57 2001
-@@ -224,10 +224,12 @@
- }
- *htaborg = htab_ra;
- *htabmask = MASKED32(htab_nr_bytes - 1, 7, 31-6);
-+#if 0
- if ((htab_ra & INSERTED32(*htabmask, 7, 15)) != 0) {
- device_error(parent, "htaborg 0x%lx not aligned to htabmask 0x%lx",
- (unsigned long)*htaborg, (unsigned long)*htabmask);
- }
-+#endif
- DTRACE(htab, ("htab - htaborg=0x%lx htabmask=0x%lx\n",
- (unsigned long)*htaborg, (unsigned long)*htabmask));
- }
diff --git a/emulators/psim-freebsd/files/patch-lf.c b/emulators/psim-freebsd/files/patch-lf.c
deleted file mode 100644
index 49fe575089df..000000000000
--- a/emulators/psim-freebsd/files/patch-lf.c
+++ /dev/null
@@ -1,53 +0,0 @@
---- sim/ppc/lf.c 2003/10/20 23:08:19 1.1
-+++ sim/ppc/lf.c 2003/10/20 23:09:15
-@@ -273,28 +273,28 @@
- switch (file->type) {
- case lf_is_c:
- case lf_is_h:
-- nr += lf_printf(file, "\
--/* This file is part of the program psim.
--
-- Copyright (C) 1994-1995, Andrew Cagney <cagney@highland.com.au>
--
-- This program is free software; you can redistribute it and/or modify
-- it under the terms of the GNU General Public License as published by
-- the Free Software Foundation; either version 2 of the License, or
-- (at your option) any later version.
--
-- This program is distributed in the hope that it will be useful,
-- but WITHOUT ANY WARRANTY; without even the implied warranty of
-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
-- along with this program; if not, write to the Free Software
-- Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
--
-- --
--
-- This file was generated by the program %s */
-+ nr += lf_printf(file, "\n\
-+/* This file is part of the program psim.\n\
-+\n\
-+ Copyright (C) 1994-1995, Andrew Cagney <cagney@highland.com.au>\n\
-+\n\
-+ This program is free software; you can redistribute it and/or modify\n\
-+ it under the terms of the GNU General Public License as published by\n\
-+ the Free Software Foundation; either version 2 of the License, or\n\
-+ (at your option) any later version.\n\
-+\n\
-+ This program is distributed in the hope that it will be useful,\n\
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of\n\
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the\n\
-+ GNU General Public License for more details.\n\
-+ \n\
-+ You should have received a copy of the GNU General Public License\n\
-+ along with this program; if not, write to the Free Software\n\
-+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.\n\
-+ \n\
-+ --\n\
-+\n\
-+ This file was generated by the program %s */\n\
- ", filter_filename(file->program));
- break;
- default: