aboutsummaryrefslogtreecommitdiff
path: root/emulators/pyxmame/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/pyxmame/Makefile')
-rw-r--r--emulators/pyxmame/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/emulators/pyxmame/Makefile b/emulators/pyxmame/Makefile
new file mode 100644
index 000000000000..25fe9a54113a
--- /dev/null
+++ b/emulators/pyxmame/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pyxmame
+# Date created: 2006-08-01
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyxmame
+PORTVERSION= 0.3.1
+CATEGORIES= emulators python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Simple frontend for the xmame
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygtk.pth:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ ${PYTHON_SITELIBDIR}/pexpect.py:${PORTSDIR}/misc/py-pexpect \
+ xmame:${PORTSDIR}/emulators/xmame
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+NO_BUILD= yes
+
+.include <bsd.port.mk>