aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile97
1 files changed, 0 insertions, 97 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
deleted file mode 100644
index 61087cfb7139..000000000000
--- a/emulators/qemu-devel/Makefile
+++ /dev/null
@@ -1,97 +0,0 @@
-# New ports collection makefile for: qemu
-# Date created: 2004/05/31
-# Whom: Juergen Lock <nox@jelal.kn-bremen.de>
-#
-# $FreeBSD$
-#
-
-PORTNAME= qemu
-PORTVERSION= 0.8.0
-PORTREVISION= 3
-CATEGORIES= emulators
-MASTER_SITES= http://www.qemu.org/:release \
- http://people.fruitsalad.org/nox/qemu/:snapshot \
- http://www.volny.cz/xnavara/qemu/:snapshot \
- http://qemu.dad-answers.com/download/qemu/:snapshot \
- http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
- http://people.freebsd.org/~maho/qemu/:misc
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
-.if defined (WITH_HACKS)
-DISTFILES+= qemu_dma_patch.tar.gz:idedma patch3_cirrus:misc
-.endif
-DIST_SUBDIR= qemu
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-
-MAINTAINER= nox@jelal.kn-bremen.de
-COMMENT= QEMU CPU Emulator
-
-BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
-.if defined(WITH_SAMBA)
-RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba
-.endif
-.if defined(WITH_KQEMU)
-BUILD_DEPENDS+= ${LOCALBASE}/include/kqemu/kqemu.h:${PORTSDIR}/emulators/kqemu-kmod
-.endif
-
-HAS_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GETOPT_LONG= yes
-USE_SDL= sdl
-USE_PERL5= yes
-PATCH_STRIP= -p1
-CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
-MAKE_ENV+= BSD_MAKE=${MAKE}
-MAN1= qemu.1 qemu-img.1
-ONLY_FOR_ARCHS= amd64 i386
-.if defined(WITH_KQEMU)
-CONFIGURE_ARGS+= --enable-kqemu
-.else
-CONFIGURE_ARGS+= --disable-kqemu
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-MAKE_ARGS+= ARCH=x86_64
-.endif
-USE_GCC= 3.4
-
-pre-everything::
-.if !defined(WITH_KQEMU)
- @${ECHO_MSG} "Notice: you can build qemu with the (alpha!) kqemu accelerator kernel module"
- @${ECHO_MSG} "by defining WITH_KQEMU."
-.endif
-.if !defined(WITH_HACKS)
- @${ECHO_MSG} "You can build qemu with some hacks (esp. for speedup)"
- @${ECHO_MSG} "by defining WITH_HACKS."
- @${ECHO_MSG} "1. IDE Bus-master DMA Support by John Coiner"
- @${ECHO_MSG} "http://people.brandeis.edu/~jcoiner/qemu_idedma/qemu_dma_patch.html"
- @${ECHO_MSG} "2. higher speed on large display (cirrus_vga) by Juergen Pfennig"
- @${ECHO_MSG} "http://lists.gnu.org/archive/html/qemu-devel/2006-01/msg00208.html"
-.endif
-.if !defined(WITH_SAMBA) && !exists(${LOCALBASE}/sbin/smbd)
- @${ECHO_MSG} "Notice: if you need qemu's -smb option (smb-export local dir to guest)"
- @${ECHO_MSG} "then you also need samba, you can have this port install it by defining"
- @${ECHO_MSG} "WITH_SAMBA."
-.endif
-
-post-extract:
- @${MKDIR} ${WRKSRC}/kqemu
- @${TOUCH} ${WRKSRC}/kqemu/Makefile
- @${ECHO} all: > ${WRKSRC}/kqemu/Makefile.freebsd
-
-pre-patch:
- @for A in ${ONLY_FOR_ARCHS}; do \
- ${MKDIR} ${WRKSRC}/bsd/$$A; \
- done
-
-post-patch:
-.if defined(WITH_HACKS)
- @cd ${WRKDIR} ; ${TAR} xfz ${DISTDIR}/${DIST_SUBDIR}/qemu_dma_patch.tar.gz ; ${CP} new_qemu_dma_patch/bios.bin ${WRKSRC}/pc-bios; cd ${WRKSRC}; ${PATCH} --quiet -p1 < ../new_qemu_dma_patch/qemu-piix4-udma.patch
- @cd ${WRKSRC} ; ${PATCH} --quiet < ${DISTDIR}/${DIST_SUBDIR}/patch3_cirrus
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>