aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-sbruno
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu-sbruno')
-rw-r--r--emulators/qemu-sbruno/Makefile1
-rw-r--r--emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c13
2 files changed, 9 insertions, 5 deletions
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index 92d17586f32e..d450f40f0607 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qemu
PORTVERSION= 2.2.50.g20150310
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= GH GHC \
LOCAL/nox \
diff --git a/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c b/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
index e9a250ca0e20..3da008cb4ec6 100644
--- a/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
+++ b/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
@@ -1,11 +1,14 @@
--- a/bsd-user/freebsd/os-proc.c
+++ b/bsd-user/freebsd/os-proc.c
-@@ -364,7 +364,7 @@ execve_end:
- #error __FreeBSD_version not defined!
+@@ -365,8 +365,10 @@ execve_end:
#endif
--#if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510
-+#if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510 && defined(PROC_REAP_ACQUIRE)
-
+ #if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510
+-
#include <sys/procctl.h>
++#endif
++
++#if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510 && defined(PROC_REAP_ACQUIRE)
+ static abi_long
+ t2h_procctl_cmd(int target_cmd, int *host_cmd)