aboutsummaryrefslogtreecommitdiff
path: root/emulators/sdlmame-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/sdlmame-devel/Makefile')
-rw-r--r--emulators/sdlmame-devel/Makefile46
1 files changed, 0 insertions, 46 deletions
diff --git a/emulators/sdlmame-devel/Makefile b/emulators/sdlmame-devel/Makefile
deleted file mode 100644
index 6e925bc6cd32..000000000000
--- a/emulators/sdlmame-devel/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# New ports collection makefile for: sdlmame
-# Date created: 2007-01-10
-# Whom: alepulver
-#
-# $FreeBSD$
-#
-
-PORTNAME= sdlmame
-PORTVERSION= 0.114u2
-CATEGORIES= emulators
-MASTER_SITES= http://rbelmont.mameworld.info/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
-
-MAINTAINER= alepulver@FreeBSD.org
-COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
-
-USE_ZIP= yes
-USE_GL= yes
-USE_GMAKE= yes
-USE_SDL= sdl
-MAKEFILE= makefile
-
-SUB_FILES= ${PORTNAME} pkg-message
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for f in obj/mame/file2str obj/mame/png2bdc mame testkeys romcmp chdman \
- jedutil makemeta regrep srcclean
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${PORTNAME}
-.endfor
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/ui.bdf ${DATADIR}
- ${CP} -R ${WRKSRC}/keymaps ${DATADIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
- ${CP} -R ${WRKSRC}/docs ${DOCSDIR}
-.endif
-
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-
-.include <bsd.port.mk>