aboutsummaryrefslogtreecommitdiff
path: root/emulators/sdlmame-devel
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/sdlmame-devel')
-rw-r--r--emulators/sdlmame-devel/Makefile46
-rw-r--r--emulators/sdlmame-devel/distinfo3
-rw-r--r--emulators/sdlmame-devel/files/patch-makefile132
-rw-r--r--emulators/sdlmame-devel/files/pkg-message.in13
-rw-r--r--emulators/sdlmame-devel/files/sdlmame.in19
-rw-r--r--emulators/sdlmame-devel/pkg-descr17
-rw-r--r--emulators/sdlmame-devel/pkg-plist27
7 files changed, 0 insertions, 257 deletions
diff --git a/emulators/sdlmame-devel/Makefile b/emulators/sdlmame-devel/Makefile
deleted file mode 100644
index 6e925bc6cd32..000000000000
--- a/emulators/sdlmame-devel/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# New ports collection makefile for: sdlmame
-# Date created: 2007-01-10
-# Whom: alepulver
-#
-# $FreeBSD$
-#
-
-PORTNAME= sdlmame
-PORTVERSION= 0.114u2
-CATEGORIES= emulators
-MASTER_SITES= http://rbelmont.mameworld.info/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
-
-MAINTAINER= alepulver@FreeBSD.org
-COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
-
-USE_ZIP= yes
-USE_GL= yes
-USE_GMAKE= yes
-USE_SDL= sdl
-MAKEFILE= makefile
-
-SUB_FILES= ${PORTNAME} pkg-message
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for f in obj/mame/file2str obj/mame/png2bdc mame testkeys romcmp chdman \
- jedutil makemeta regrep srcclean
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${PORTNAME}
-.endfor
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/ui.bdf ${DATADIR}
- ${CP} -R ${WRKSRC}/keymaps ${DATADIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
- ${CP} -R ${WRKSRC}/docs ${DOCSDIR}
-.endif
-
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-
-.include <bsd.port.mk>
diff --git a/emulators/sdlmame-devel/distinfo b/emulators/sdlmame-devel/distinfo
deleted file mode 100644
index e941ddb81866..000000000000
--- a/emulators/sdlmame-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (sdlmame0114u2.zip) = 3dd231806930b850b26f23924cd011f0
-SHA256 (sdlmame0114u2.zip) = b287f54f78a9a8e62509e72813836ccff54e594d986a28c2f4a8b528beac1a50
-SIZE (sdlmame0114u2.zip) = 15315293
diff --git a/emulators/sdlmame-devel/files/patch-makefile b/emulators/sdlmame-devel/files/patch-makefile
deleted file mode 100644
index d839b1ec02ca..000000000000
--- a/emulators/sdlmame-devel/files/patch-makefile
+++ /dev/null
@@ -1,132 +0,0 @@
---- makefile.orig Thu Apr 12 22:01:33 2007
-+++ makefile Sat Apr 21 13:20:41 2007
-@@ -63,11 +63,13 @@
- # uncomment next line to include the debugger
- # DEBUG = 1
-
-+ifeq ($(ARCH),i386)
- # uncomment next line to use DRC MIPS3 engine
- X86_MIPS3_DRC = 1
-
- # uncomment next line to use DRC PowerPC engine
- X86_PPC_DRC = 1
-+endif
-
- #-------------------------------------------------
- # specify build options; see each option below
-@@ -174,8 +176,8 @@
-
- # compiler, linker and utilities
- AR = @ar
--CC = @gcc
--LD = @gcc
-+CC := @$(CC)
-+LD = @$(CC)
- MD = -mkdir
- RM = @rm -f
-
-@@ -191,53 +193,12 @@
- endif
-
- # by default, don't compile for a specific target CPU
--NAME = $(PREFIX)$(TARGET)
--ARCH =
--
--# architecture-specific builds get extra options
--ifdef ATHLON
--NAME = $(PREFIX)$(TARGET)at
--ARCH = -march=athlon
--endif
--
--ifdef I686
--NAME = $(PREFIX)$(TARGET)pp
--ARCH = -march=pentiumpro
--endif
--
--ifdef P4
--NAME = $(PREFIX)$(TARGET)p4
--ARCH = -march=pentium4
--endif
--
--ifdef AMD64
--NAME = $(PREFIX)$(TARGET)64
--ARCH = -march=athlon64
--endif
--
--ifdef PM
--NAME = $(PREFIX)$(TARGET)pm
--ARCH = -march=pentium3 -msse2
--endif
--
--ifdef G4
--NAME = $(PREFIX)$(TARGET)g4
--ARCH = -mcpu=G4
--endif
--
--ifdef G5
--NAME = $(PREFIX)$(TARGET)g5
--ARCH = -mcpu=G5
--endif
--
--ifdef CELL
--NAME = $(PREFIX)$(TARGET)cbe
-+NAME = $(TARGET)
- ARCH =
--endif
-
- # debug builds just get the 'd' suffix and nothing more
- ifdef DEBUG
--NAME = $(PREFIX)$(TARGET)d
-+NAME = $(TARGET)d
- endif
-
- EMULATOR = $(NAME)$(EXE)
-@@ -275,7 +236,7 @@
- # compile and linking flags
- #-------------------------------------------------
-
--CFLAGS = \
-+CFLAGS += \
- $(OPT_FLAGS) \
- -std=gnu89 \
- -I$(SRC)/$(TARGET) \
-@@ -287,6 +248,7 @@
- -I$(SRC)/lib/util \
- -I$(SRC)/osd \
- -I$(SRC)/osd/$(MAMEOS) \
-+ -I$(LOCALBASE)/include -I$(X11BASE)/include
-
- ifdef MESS
- CFLAGS += \
-@@ -305,7 +267,7 @@
- endif # PPC
- endif # SYMBOLS
-
--CFLAGS += $(ARCH) \
-+CFLAGS += \
- -Wall \
- -Wpointer-arith \
- -Wbad-function-cast \
-@@ -317,7 +279,7 @@
- -Wdeclaration-after-statement
-
- ifneq ($(OPTIMIZE),0)
--CFLAGS += -DNDEBUG $(ARCH) -fno-strict-aliasing
-+CFLAGS += -DNDEBUG -fno-strict-aliasing
- endif
-
- CFLAGS += -O$(OPTIMIZE)
-@@ -325,11 +287,9 @@
- # extra options needed *only* for the osd files
- CFLAGSOSDEPEND = $(CFLAGS)
-
--LDFLAGS = -WO
-+LDFLAGS += -WO -L$(LOCALBASE)/lib -L$(X11BASE)/lib
-
--ifdef SYMBOLS
--LDFLAGS =
--else
-+ifndef SYMBOLS
- LDFLAGS += -s
- endif
-
diff --git a/emulators/sdlmame-devel/files/pkg-message.in b/emulators/sdlmame-devel/files/pkg-message.in
deleted file mode 100644
index 3290fa533a30..000000000000
--- a/emulators/sdlmame-devel/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
-==============================================================================
-
-SDLMAME has been installed.
-
-The MAME tools are installed in "%%PREFIX%%/libexec/sdlmame"
-to avoid conflicting with other MAME ports.
-
-A wrapper script "sdlmame" has been installed. It creates a "~/.sdlmame"
-directory mirroring the directory tree under "%%DATADIR%%"
-when you run it for the first time, and starts the program from there. So
-place all MAME files (e.g. ROMs, cheats, etc.) in "~/.sdlmame".
-
-==============================================================================
diff --git a/emulators/sdlmame-devel/files/sdlmame.in b/emulators/sdlmame-devel/files/sdlmame.in
deleted file mode 100644
index 9a7c7215f76a..000000000000
--- a/emulators/sdlmame-devel/files/sdlmame.in
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-#
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.cube, and create symlinks to the data files.
-#
-
-if [ -d ~/.sdlmame ]
-then
- echo "Using existing ~/.sdlmame directory."
-else
- echo "Creating ~/.sdlmame directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.sdlmame/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.sdlmame/{} \; 2>/dev/null
-fi
-
-cd ~/.sdlmame || exit 1
-exec %%PREFIX%%/libexec/sdlmame/mame "$@"
diff --git a/emulators/sdlmame-devel/pkg-descr b/emulators/sdlmame-devel/pkg-descr
deleted file mode 100644
index b297a4b68fa9..000000000000
--- a/emulators/sdlmame-devel/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-SDLMAME is a port of the popular MAME. There are a few principles that guide
-it's development:
-
-1) Run on Linux/Unix, Mac OS X, and other SDL supported operating systems with
- as few changes as possible to the base Win32 code. This means we can track
- changes faster than larger more conventional ports such as MacMAME, and we
- also maintain what I call "Firefox compatibilty" where learning a major app
- only needs to be done once per application, and it then applies across many
- operating systems. If you can use the command-line Win32 MAME, you already
- know how to use SDLMAME on any platform you may encounter it on.
-
-2) MAME developers are important. By keeping quickly up to date, we make it
- easy for people on non-Windows platforms to make and submit changes to the
- core MAME code, and we offer native implementations of MAME's multi-window
- GUI debugger on both Linux/Unix and Mac OS X.
-
-WWW: http://rbelmont.mameworld.info/?page_id=163
diff --git a/emulators/sdlmame-devel/pkg-plist b/emulators/sdlmame-devel/pkg-plist
deleted file mode 100644
index 2e305d044313..000000000000
--- a/emulators/sdlmame-devel/pkg-plist
+++ /dev/null
@@ -1,27 +0,0 @@
-bin/sdlmame
-libexec/sdlmame/chdman
-libexec/sdlmame/file2str
-libexec/sdlmame/jedutil
-libexec/sdlmame/makemeta
-libexec/sdlmame/mame
-libexec/sdlmame/png2bdc
-libexec/sdlmame/regrep
-libexec/sdlmame/romcmp
-libexec/sdlmame/srcclean
-libexec/sdlmame/testkeys
-%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
-%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
-%%PORTDOCS%%%%DOCSDIR%%/whatsnew_0114u2.txt
-%%DATADIR%%/keymaps/km-ch.txt
-%%DATADIR%%/keymaps/km-fr-OSX.txt
-%%DATADIR%%/keymaps/km-fr.txt
-%%DATADIR%%/ui.bdf
-@dirrm %%DATADIR%%/keymaps
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm libexec/sdlmame