aboutsummaryrefslogtreecommitdiff
path: root/emulators/sim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/sim/Makefile')
-rw-r--r--emulators/sim/Makefile31
1 files changed, 22 insertions, 9 deletions
diff --git a/emulators/sim/Makefile b/emulators/sim/Makefile
index 1c6ba2380264..7914bab93fff 100644
--- a/emulators/sim/Makefile
+++ b/emulators/sim/Makefile
@@ -6,39 +6,52 @@
#
PORTNAME= sim
-PORTVERSION= 2.9.11
+PORTVERSION= 2.10.1
CATEGORIES= emulators
MASTER_SITES= http://simh.trailing-edge.com/sources/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=jedgar
-DISTNAME= ${PORTNAME}hv29-11
+DISTNAME= ${PORTNAME}hv210-1
MAINTAINER= jedgar@FreeBSD.org
USE_ZIP= yes
+USE_GMAKE= yes
RESTRICTED= "Non-commercial use only"
-MAKEFILE= ${FILESDIR}/Makefile
+MAKEFILE= makefile
NO_WRKSUBDIR= yes
SHELL=${SH}
-BIN_FILES= altair eclipse h316 nova pdp1 pdp10 pdp11 pdp15 pdp4 pdp7 pdp8 \
- pdp9 s3
+BIN_FILES= altair h316 ibm1130 pdp11 pdp8 \
+ altairz80 hp2100 nova pdp15 pdp9 \
+ eclipse i1401 pdp1 pdp4 s3 \
+ gri i1620 pdp10 pdp7 vax \
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
- @for i in `find ${WRKSRC} -name "*.[hc]"`; do \
- cat $$i | ${TR} -d '\r' > $$i.new; \
- mv $$i.new $$i; \
+ @for i in ${WRKSRC}/makefile `find ${WRKSRC} -name "*.[hc]"`; do \
+ ${CAT} $$i | ${TR} -d '\r' > $$i.new; \
+ ${MV} $$i.new $$i; \
done
do-install:
.for file in ${BIN_FILES}
${INSTALL_PROGRAM} ${WRKDIR}/BIN/${file} ${PREFIX}/bin
.endfor
+
+ @${MKDIR} ${PREFIX}/share/sim
+ ${INSTALL_DATA} ${WRKDIR}/VAX/ka655.bin ${PREFIX}/share/sim
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/sim
- @${INSTALL_DATA} ${WRKDIR}/simh_doc.txt ${PREFIX}/share/doc/sim
+ @for i in 0readme_210.txt 0readme_ethernet.txt \
+ simh_doc.txt simh_swre.txt; do \
+ ${INSTALL_DATA} ${WRKDIR}/$$i ${PREFIX}/share/doc/sim; \
+ done
.endif
+post-install:
+ @${CAT} pkg-message
+
.include <bsd.port.mk>