aboutsummaryrefslogtreecommitdiff
path: root/emulators/simh
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/simh')
-rw-r--r--emulators/simh/Makefile6
-rw-r--r--emulators/simh/distinfo4
-rw-r--r--emulators/simh/files/patch-makefile8
3 files changed, 9 insertions, 9 deletions
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index 5a277fcfbf53..3658fc31156e 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= sim
-PORTVERSION= 3.2.0
+PORTVERSION= 3.4.0
CATEGORIES= emulators
MASTER_SITES= http://simh.trailing-edge.com/sources/
-DISTNAME= ${PORTNAME}hv32-0
+DISTNAME= ${PORTNAME}hv34-0
MAINTAINER= jedgar@FreeBSD.org
COMMENT= PDP-8, PDP-11, PDP-1, other 18b PDP, Nova, and IBM 1401 simulators
@@ -28,7 +28,7 @@ BIN_FILES= pdp1 pdp4 pdp7 pdp8 pdp9 \
i1620 s3 altair altairz80 \
gri ibm1130 id16 id32 sds lgp
-PORTDOCS= 0readme_32.txt simh_doc.txt simh_swre.txt \
+PORTDOCS= 0readme_34.txt simh_doc.txt simh_swre.txt \
0readme_ethernet.txt simh_faq.txt
PLIST_FILES= ${BIN_FILES:S/^/bin\//g} share/sim/ka655.bin share/sim/ka655x.bin
diff --git a/emulators/simh/distinfo b/emulators/simh/distinfo
index 60302168ecdf..6cb6a6759e2b 100644
--- a/emulators/simh/distinfo
+++ b/emulators/simh/distinfo
@@ -1,2 +1,2 @@
-MD5 (simhv32-0.zip) = 431a1b7915e9aa9253eab83a366590bf
-SIZE (simhv32-0.zip) = 1914305
+MD5 (simhv34-0.zip) = 64d6153312257fcadf5c704cb939cf0c
+SIZE (simhv34-0.zip) = 2138255
diff --git a/emulators/simh/files/patch-makefile b/emulators/simh/files/patch-makefile
index faa54a9b6722..6d771593e784 100644
--- a/emulators/simh/files/patch-makefile
+++ b/emulators/simh/files/patch-makefile
@@ -1,11 +1,11 @@
---- makefile.orig Wed Jun 23 18:01:06 2004
-+++ makefile Wed Jun 23 18:01:50 2004
+--- makefile.orig Mon Aug 22 18:36:56 2005
++++ makefile Mon Aug 22 18:37:56 2005
@@ -10,7 +10,7 @@
else
OS_CCDEFS = -D_GNU_SOURCE
endif
--CC = gcc -std=c99 -O2 -g -lm $(OS_CCDEFS) -I .
+-CC = gcc -std=c99 -O2 -U__STRICT_ANSI__ -g -lm $(OS_CCDEFS) -I .
+CC += ${CFLAGS} -lm $(OS_CCDEFS) -I .
ifeq ($(USE_NETWORK),)
else
- NETWORK_OPT = -DUSE_NETWORK -lpcap -isystem /usr/local/include -L /usr/local/lib
+ NETWORK_OPT = -DUSE_NETWORK -isystem /usr/local/include /usr/local/lib/libpcap.a