aboutsummaryrefslogtreecommitdiff
path: root/emulators/ski
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/ski')
-rw-r--r--emulators/ski/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/emulators/ski/Makefile b/emulators/ski/Makefile
index 0e0fa4efc65e..2b724e72d45b 100644
--- a/emulators/ski/Makefile
+++ b/emulators/ski/Makefile
@@ -20,9 +20,8 @@ EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
ONLY_FOR_ARCHS= i386
-NOTICE= -- please manually download ${DISTNAME}${EXTRACT_SUFX} from the HP site (http://www.hpl.hp.com/research/linux/ski/download.php) and put it in ${DISTDIR} first. License restrictions disallow automatic downloads and redistribution of the software.
-NO_PACKAGE= ${NOTICE}
-NO_CDROM= ${NOTICE}
+NOTICE= -- please manually download ${DISTNAME}${EXTRACT_SUFX} from the HP site (http://www.hpl.hp.com/research/linux/ski/download.php) and put it in ${DISTDIR} first
+RESTRICTED= License restrictions disallow automatic downloads and redistribution of the software.
EXTRACT_CMD= rpm2cpio.pl
EXTRACT_BEFORE_ARGS=
@@ -54,7 +53,7 @@ do-install:
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= ${NOTICE}
.endif