aboutsummaryrefslogtreecommitdiff
path: root/emulators/stonx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/stonx/Makefile')
-rw-r--r--emulators/stonx/Makefile44
1 files changed, 19 insertions, 25 deletions
diff --git a/emulators/stonx/Makefile b/emulators/stonx/Makefile
index 31a751330952..6ab3cc3be5bc 100644
--- a/emulators/stonx/Makefile
+++ b/emulators/stonx/Makefile
@@ -13,7 +13,8 @@ COMMENT= AtariST emulator
BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
gccmakedep:${PORTSDIR}/devel/gccmakedep \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
+ ${LOCALBASE}/lib/X11/fonts/misc/10x20-ISO8859-1.pcf.gz:${PORTSDIR}/x11-fonts/font-misc-misc
RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
RESTRICTED= tos.img is copyrighted
@@ -26,11 +27,6 @@ CONFIGURE_ARGS= --x-includes=${LOCALBASE}/include \
--x-libraries=${LOCALBASE}/lib
ALL_TARGET= all fnttobdf tosfonts fonts
-pre-build:
- ${CP} ${DISTDIR}/${TOSIMG} ${WRKSRC}/tos.img
-
-# Installing
-#
BINDIR= ${PREFIX}/bin
FNTDIR= ${PREFIX}/lib/X11/fonts/misc
@@ -41,6 +37,11 @@ DOCS= ../COPYING AUTHORS DEBUGGING INSTALL README RELEASE_NOTES \
FONTS= System0-iso.pcf System0.pcf System1-iso.pcf System1.pcf \
System2-iso.pcf System2.pcf
+.include <bsd.port.options.mk>
+
+pre-build:
+ ${CP} ${DISTDIR}/${TOSIMG} ${WRKSRC}/tos.img
+
post-install:
.for f in ${ETCFILES}
${INSTALL_DATA} ${WRKSRC}/etc/$f ${ETCDIR}/
@@ -48,32 +49,25 @@ post-install:
@${ECHO_MSG} "===> Installing fonts"
.for f in ${FONTS}
${INSTALL_DATA} ${WRKSRC}/data/$f ${FNTDIR}/
- @${GZIP_CMD} ${FNTDIR}/$f
-.endfor
- @mkfontdir ${FNTDIR}
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing docs"
- @${MKDIR} ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/$f ${DOCSDIR}/
-.endfor
- @${MKDIR} ${EXAMPLESDIR}
-.for f in ${DATA}
- ${INSTALL_DATA} ${WRKSRC}/$f ${EXAMPLESDIR}/
+ ${GZIP_CMD} ${FNTDIR}/$f
.endfor
+ mkfontdir ${FNTDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/docs/,} ${DOCSDIR}/
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${DATA:S,^,${WRKSRC}/,} ${EXAMPLESDIR}/
.endif
.if (defined(DISPLAY) && ${DISPLAY} != "")
- @xset fp+ ${FNTDIR}
- @xset fp rehash
+ xset fp+ ${FNTDIR}
+ xset fp rehash
.endif
-.include <bsd.port.pre.mk>
-
.if !exists(${DISTDIR}/${TOSIMG})
IGNORE= please get a ROM dump from your AtariST and save it as\
"${TOSIMG}" in "${DISTDIR}" manually, and then make again
.endif
-BUILD_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/misc/10x20-ISO8859-1.pcf.gz:${PORTSDIR}/x11-fonts/font-misc-misc
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>