aboutsummaryrefslogtreecommitdiff
path: root/emulators/uae/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/uae/Makefile')
-rw-r--r--emulators/uae/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/emulators/uae/Makefile b/emulators/uae/Makefile
new file mode 100644
index 000000000000..767c7dc2dcba
--- /dev/null
+++ b/emulators/uae/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: uae
+# Date created: 22 May 2000
+# Whom: Simon Dick <simond@irrelevant.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uae
+PORTVERSION= 0.7.6
+CATEGORIES= emulators
+MASTER_SITES= ftp://ftp.freiburg.linux.de/pub/uae/ \
+ http://www.users.globalnet.co.uk/~simd/
+
+MAINTAINER= simond@irrelevant.org
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-sound
+USE_XLIB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/uae ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/readdisk ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/doc/uae
+ ${INSTALL_DATA} ${WRKSRC}/docs/COMPATIBILITY ${PREFIX}/share/doc/uae
+ ${INSTALL_DATA} ${WRKSRC}/docs/CREDITS ${PREFIX}/share/doc/uae
+ ${INSTALL_DATA} ${WRKSRC}/docs/FAQ ${PREFIX}/share/doc/uae
+ ${INSTALL_DATA} ${WRKSRC}/docs/NEWS ${PREFIX}/share/doc/uae
+ ${INSTALL_DATA} ${WRKSRC}/docs/README ${PREFIX}/share/doc/uae
+ ${INSTALL_DATA} ${WRKSRC}/docs/README.PROGRAMMERS ${PREFIX}/share/doc/uae
+ ${INSTALL_DATA} ${WRKSRC}/docs/unix/README ${PREFIX}/share/doc/uae/README.unix
+
+.include <bsd.port.mk>