aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose/files
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/virtualbox-ose/files')
-rw-r--r--emulators/virtualbox-ose/files/patch-configure10
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Additions-common-VBoxService-VBoxServiceVMInfo.cpp10
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Additions-x11-VBoxClient-Makefile.kmk20
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-HostDrivers-Support-SUPR3HardenedMain.cpp33
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Main-include-ConsoleImpl.h18
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Runtime-VBox-log-vbox.cpp82
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Runtime-r3-freebsd-rtProcInitExePath-freebsd.cpp81
7 files changed, 14 insertions, 240 deletions
diff --git a/emulators/virtualbox-ose/files/patch-configure b/emulators/virtualbox-ose/files/patch-configure
index a4aaf507ccc9..ba2a1c428bcd 100644
--- a/emulators/virtualbox-ose/files/patch-configure
+++ b/emulators/virtualbox-ose/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2009-12-17 15:23:05.000000000 +0100
-+++ configure 2009-12-21 14:25:45.000000000 +0100
+--- configure.orig 2010-01-28 16:34:50.000000000 +0100
++++ configure 2010-01-28 22:16:50.000000000 +0100
@@ -107,7 +107,7 @@
GENISOIMAGE="genisoimage"
MKISOFS="mkisofs"
@@ -36,7 +36,7 @@
if [ $? -eq 0 ]; then
found=1
break
-@@ -2315,6 +2317,15 @@
+@@ -2318,6 +2320,15 @@
[ $WITH_QT4 -eq 1 ] && check_qt4
[ $WITH_PYTHON -eq 1 ] && check_python
@@ -52,13 +52,13 @@
# Linux-specific
if [ "$OS" = "linux" ]; then
# don't check for the static libstdc++ in the PUEL version as we build the
-@@ -2332,11 +2343,6 @@
+@@ -2335,11 +2346,6 @@
else
cnf_append "VBOX_WITH_ALSA" ""
fi
- if [ $WITH_PULSE -eq 1 ]; then
- check_pulse
-- else
+- elif [ $WITH_PULSE -eq 0 ]; then
- cnf_append "VBOX_WITH_PULSE" ""
- fi
if [ $WITH_DBUS -eq 0 ]; then
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Additions-common-VBoxService-VBoxServiceVMInfo.cpp b/emulators/virtualbox-ose/files/patch-src-VBox-Additions-common-VBoxService-VBoxServiceVMInfo.cpp
deleted file mode 100644
index 408d858c1f13..000000000000
--- a/emulators/virtualbox-ose/files/patch-src-VBox-Additions-common-VBoxService-VBoxServiceVMInfo.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/VBox/Additions/common/VBoxService/VBoxServiceVMInfo.cpp.orig 2010-01-18 10:53:11.000000000 +0100
-+++ src/VBox/Additions/common/VBoxService/VBoxServiceVMInfo.cpp 2010-01-18 10:53:18.000000000 +0100
-@@ -38,7 +38,6 @@
- # include <sys/socket.h>
- # include <net/if.h>
- # include <unistd.h>
--# include <utmp.h>
- # ifdef RT_OS_SOLARIS
- # include <sys/sockio.h>
- # endif
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Additions-x11-VBoxClient-Makefile.kmk b/emulators/virtualbox-ose/files/patch-src-VBox-Additions-x11-VBoxClient-Makefile.kmk
deleted file mode 100644
index cc5553f7736d..000000000000
--- a/emulators/virtualbox-ose/files/patch-src-VBox-Additions-x11-VBoxClient-Makefile.kmk
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: src/VBox/Additions/x11/VBoxClient/Makefile.kmk
-===================================================================
---- src/VBox/Additions/x11/VBoxClient/Makefile.kmk (revision 25472)
-+++ src/VBox/Additions/x11/VBoxClient/Makefile.kmk (revision 25473)
-@@ -43,11 +43,14 @@
- $(VBOX_LIBPATH32_X11)
- VBoxClient_LIBS.freebsd = \
- iconv
-+VBoxClient_LIBS.linux = \
-+ dl
-+VBoxClient_LIBS.solaris = \
-+ dl
- VBoxClient_LIBS = \
- $(VBOX_LIB_IPRT_GUEST_R3) \
- $(VBOX_LIB_VBGL_R3) \
- $(VBOX_LIB_IPRT_GUEST_R3) \
-- dl \
- X11 \
- Xt
- # These are static replacements for gcc-specific parts of libstdc++
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-HostDrivers-Support-SUPR3HardenedMain.cpp b/emulators/virtualbox-ose/files/patch-src-VBox-HostDrivers-Support-SUPR3HardenedMain.cpp
deleted file mode 100644
index 4a89fec97dfa..000000000000
--- a/emulators/virtualbox-ose/files/patch-src-VBox-HostDrivers-Support-SUPR3HardenedMain.cpp
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/VBox/HostDrivers/Support/SUPR3HardenedMain.cpp (revision 25471)
-+++ src/VBox/HostDrivers/Support/SUPR3HardenedMain.cpp (revision 25472)
-@@ -66,6 +66,9 @@
- # ifndef CAP_TO_MASK
- # define CAP_TO_MASK(cap) RT_BIT(cap)
- # endif
-+# elif defined(RT_OS_FREEBSD)
-+# include <sys/param.h>
-+# include <sys/sysctl.h>
- # elif defined(RT_OS_SOLARIS)
- # include <priv.h>
- # endif
-@@ -325,7 +328,19 @@
- sprintf(szFileBuf, "/proc/%ld/path/a.out", (long)getpid());
- int cchLink = readlink(szFileBuf, &g_szSupLibHardenedExePath[0], sizeof(g_szSupLibHardenedExePath) - 1);
- # else /* RT_OS_FREEBSD: */
-- int cchLink = readlink("/proc/curproc/file", &g_szSupLibHardenedExePath[0], sizeof(g_szSupLibHardenedExePath) - 1);
-+ int aiName[4];
-+ size_t cbPath;
-+
-+ aiName[0] = CTL_KERN;
-+ aiName[1] = KERN_PROC;
-+ aiName[2] = KERN_PROC_PATHNAME;
-+ aiName[3] = getpid();
-+
-+ cbPath = sizeof(g_szSupLibHardenedExePath) - 1;
-+ if(sysctl(aiName, RT_ELEMENTS(aiName), g_szSupLibHardenedExePath, &cbPath, NULL, 0) < 0)
-+ supR3HardenedFatal("supR3HardenedExecDir: sysctl failed\n");
-+
-+ int cchLink = strlen(g_szSupLibHardenedExePath);
- # endif
- if (cchLink < 0 || cchLink == sizeof(g_szSupLibHardenedExePath) - 1)
- supR3HardenedFatal("supR3HardenedExecDir: couldn't read \"%s\", errno=%d cchLink=%d\n",
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Main-include-ConsoleImpl.h b/emulators/virtualbox-ose/files/patch-src-VBox-Main-include-ConsoleImpl.h
index 2471480886d8..d363775e3da9 100644
--- a/emulators/virtualbox-ose/files/patch-src-VBox-Main-include-ConsoleImpl.h
+++ b/emulators/virtualbox-ose/files/patch-src-VBox-Main-include-ConsoleImpl.h
@@ -1,6 +1,6 @@
---- src/VBox/Main/include/ConsoleImpl.h.orig
-+++ src/VBox/Main/include/ConsoleImpl.h
-@@ -410,7 +410,7 @@ private:
+--- src/VBox/Main/include/ConsoleImpl.h.orig 2010-02-12 19:49:27.000000000 +0000
++++ src/VBox/Main/include/ConsoleImpl.h 2010-02-13 14:26:54.000000000 +0000
+@@ -410,7 +410,7 @@
HRESULT callTapSetupApplication(bool isStatic, RTFILE tapFD, Bstr &tapDevice,
Bstr &tapSetupApplication);
@@ -9,12 +9,12 @@
HRESULT attachToTapInterface(INetworkAdapter *networkAdapter);
HRESULT detachFromTapInterface(INetworkAdapter *networkAdapter);
#endif
-@@ -582,7 +582,7 @@ private:
- PPDMLED mapNetworkLeds[SchemaDefs::NetworkAdapterCount];
- PPDMLED mapSharedFolderLed;
- PPDMLED mapUSBLed[2];
+@@ -592,7 +592,7 @@
+ PPDMLED mapNetworkLeds[SchemaDefs::NetworkAdapterCount];
+ PPDMLED mapSharedFolderLed;
+ PPDMLED mapUSBLed[2];
-#if !defined(VBOX_WITH_NETFLT) && (defined(RT_OS_LINUX) || defined(RT_OS_FREEBSD))
+#if ((defined(RT_OS_LINUX) && !defined(VBOX_WITH_NETFLT)) || defined(RT_OS_FREEBSD))
- Utf8Str maTAPDeviceName[8];
- RTFILE maTapFD[8];
+ Utf8Str maTAPDeviceName[8];
+ RTFILE maTapFD[8];
#endif
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-VBox-log-vbox.cpp b/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-VBox-log-vbox.cpp
deleted file mode 100644
index 005a25e4a79a..000000000000
--- a/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-VBox-log-vbox.cpp
+++ /dev/null
@@ -1,82 +0,0 @@
---- src/VBox/Runtime/VBox/log-vbox.cpp (revision 25471)
-+++ src/VBox/Runtime/VBox/log-vbox.cpp (revision 25472)
-@@ -135,6 +135,12 @@
- # include <Windows.h>
- # elif defined(RT_OS_LINUX)
- # include <unistd.h>
-+# elif defined(RT_OS_FREEBSD)
-+# include <sys/param.h>
-+# include <sys/sysctl.h>
-+# include <sys/user.h>
-+# include <stdlib.h>
-+# include <unistd.h>
- # elif defined(RT_OS_SOLARIS)
- # define _STRUCTURED_PROC 1
- # undef _FILE_OFFSET_BITS /* procfs doesn't like this */
-@@ -157,6 +163,7 @@
- # include <iprt/path.h>
- # include <iprt/process.h>
- # include <iprt/string.h>
-+# include <iprt/mem.h>
- # include <stdio.h>
- #endif
-
-@@ -339,12 +346,8 @@
- fclose(pFile);
- }
-
--# elif defined(RT_OS_LINUX) || defined(RT_OS_FREEBSD)
--# ifdef RT_OS_LINUX
-+# elif defined(RT_OS_LINUX)
- FILE *pFile = fopen("/proc/self/cmdline", "r");
--# else /* RT_OS_FREEBSD: */
-- FILE *pFile = fopen("/proc/curproc/cmdline", "r");
--# endif
- if (pFile)
- {
- /* braindead */
-@@ -370,7 +373,44 @@
- RTLogLoggerEx(pLogger, 0, ~0U, "\n");
- fclose(pFile);
- }
-+# elif defined(RT_OS_FREEBSD)
-+ char *pszArgFileBuf = NULL;
-+ int aiName[4];
-+ size_t cchArgs;
-
-+ aiName[0] = CTL_KERN;
-+ aiName[1] = KERN_PROC;
-+ aiName[2] = KERN_PROC_ARGS;
-+ aiName[3] = -1;
-+
-+ /* Retrieve the required length first */
-+ cchArgs = 0;
-+ int rcBSD = sysctl(aiName, RT_ELEMENTS(aiName), NULL, &cchArgs, NULL, 0);
-+
-+ if (cchArgs > 0)
-+ {
-+ pszArgFileBuf = (char *)RTMemAllocZ(cchArgs + 1 /* Safety */);
-+ if (pszArgFileBuf)
-+ {
-+ /* Retrieve the argument list */
-+ rcBSD = sysctl(aiName, RT_ELEMENTS(aiName), pszArgFileBuf, &cchArgs, NULL, 0);
-+ if (!rcBSD)
-+ {
-+ /*
-+ * cmdline is a flattened argument list so we need
-+ * to convert all \0 to blanks
-+ */
-+ for(size_t i = 0; i < cchArgs - 1; i++)
-+ {
-+ if(pszArgFileBuf[i] == '\0')
-+ pszArgFileBuf[i] = ' ';
-+ }
-+
-+ RTLogLoggerEx(pLogger, 0, ~0U, "Commandline: %s\n", pszArgFileBuf);
-+ }
-+ RTMemFree(pszArgFileBuf);
-+ }
-+ }
- # elif defined(RT_OS_L4) || defined(RT_OS_OS2) || defined(RT_OS_DARWIN)
- /* commandline? */
- # else
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-r3-freebsd-rtProcInitExePath-freebsd.cpp b/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-r3-freebsd-rtProcInitExePath-freebsd.cpp
deleted file mode 100644
index 2332212ead14..000000000000
--- a/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-r3-freebsd-rtProcInitExePath-freebsd.cpp
+++ /dev/null
@@ -1,81 +0,0 @@
---- src/VBox/Runtime/r3/freebsd/rtProcInitExePath-freebsd.cpp (revision 25471)
-+++ src/VBox/Runtime/r3/freebsd/rtProcInitExePath-freebsd.cpp (revision 25472)
-@@ -32,6 +32,8 @@
- * Header Files *
- *******************************************************************************/
- #define LOG_GROUP RTLOGGROUP_PROCESS
-+#include <sys/param.h>
-+#include <sys/sysctl.h>
- #include <unistd.h>
- #include <errno.h>
- #include <dlfcn.h>
-@@ -47,17 +49,20 @@
-
- DECLHIDDEN(int) rtProcInitExePath(char *pszPath, size_t cchPath)
- {
-- /*
-- * Read the /proc/curproc/file link, convert to native and return it.
-- */
-- int cchLink = readlink("/proc/curproc/file", pszPath, cchPath - 1);
-- if (cchLink > 0 && (size_t)cchLink <= cchPath - 1)
-- {
-- pszPath[cchLink] = '\0';
-+ int aiName[4];
-+ size_t cchExePath;
-
-+ aiName[0] = CTL_KERN;
-+ aiName[1] = KERN_PROC;
-+ aiName[2] = KERN_PROC_PATHNAME;
-+ aiName[3] = getpid();
-+
-+ cchExePath = cchPath - 1;
-+ if(sysctl(aiName, RT_ELEMENTS(aiName), pszPath, &cchExePath, NULL, 0) == 0)
-+ {
- char *pszTmp = NULL;
- int rc = rtPathFromNative(&pszTmp, pszPath);
-- AssertMsgRCReturn(rc, ("rc=%Rrc pszLink=\"%s\"\nhex: %.*Rhsx\n", rc, pszPath, cchLink, pszPath), rc);
-+ AssertMsgRCReturn(rc, ("rc=%Rrc pszLink=\"%s\"\nhex: %.*Rhsx\n", rc, pszPath, cchExePath, pszPath), rc);
-
- size_t cch = strlen(pszTmp);
- AssertReturn(cch <= cchPath, VERR_BUFFER_OVERFLOW);
-@@ -68,39 +73,8 @@
- return VINF_SUCCESS;
- }
-
-- int err = errno;
--
-- /*
-- * Fall back on the dynamic linker since /proc is optional.
-- */
-- void *hExe = dlopen(NULL, 0);
-- if (hExe)
-- {
-- struct link_map const *pLinkMap = 0;
-- if (dlinfo(hExe, RTLD_DI_LINKMAP, &pLinkMap) == 0)
-- {
-- const char *pszImageName = pLinkMap->l_name;
-- if (*pszImageName == '/') /* this may not always be absolute, despite the docs. :-( */
-- {
-- char *pszTmp = NULL;
-- int rc = rtPathFromNative(&pszTmp, pszImageName);
-- AssertMsgRCReturn(rc, ("rc=%Rrc pszImageName=\"%s\"\n", rc, pszImageName), rc);
--
-- size_t cch = strlen(pszTmp);
-- AssertReturn(cch <= cchPath, VERR_BUFFER_OVERFLOW);
--
-- memcpy(pszPath, pszTmp, cch + 1);
-- RTStrFree(pszTmp);
--
-- return VINF_SUCCESS;
-- }
-- /** @todo Try search the PATH for the file name or append the current
-- * directory, which ever makes sense... */
-- }
-- }
--
-- int rc = RTErrConvertFromErrno(err);
-- AssertMsgFailed(("rc=%Rrc err=%d cchLink=%d hExe=%p\n", rc, err, cchLink, hExe));
-+ int rc = RTErrConvertFromErrno(errno);
-+ AssertMsgFailed(("rc=%Rrc errno=%d cchLink=%d\n", rc, errno, cchExePath));
- return rc;
- }