aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/virtualbox/Makefile')
-rw-r--r--emulators/virtualbox/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/emulators/virtualbox/Makefile b/emulators/virtualbox/Makefile
index 94377f31fbcd..d0419e2d0b6f 100644
--- a/emulators/virtualbox/Makefile
+++ b/emulators/virtualbox/Makefile
@@ -76,6 +76,14 @@ KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE} VBOX_FREEBSD_SRC=${SRC_BASE}/sys
KMK_FLAGS=
+.if defined(WITHOUT_QT4) && !defined(WITHOUT_NLS)
+BROKEN= NLS support requires QT4 frontend. Run 'make config' again!
+.endif
+
+.if defined(WITHOUT_X11) && !defined(WITHOUT_QT4)
+BROKEN= QT4 frontend requires X11 support. Run 'make config' again!
+.endif
+
.if !defined(WITHOUT_X11)
USE_SDL= sdl
USE_XORG= xcursor xmu
@@ -96,7 +104,6 @@ PLIST_SUB+= QT4=""
.else
CONFIGURE_ARGS+=--disable-qt4
PLIST_SUB+= QT4="@comment "
-WITHOUT_NLS= yes
.endif
.if defined(WITH_GUESTADDITIONS)