aboutsummaryrefslogtreecommitdiff
path: root/emulators/vmware3
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/vmware3')
-rw-r--r--emulators/vmware3/Makefile3
-rw-r--r--emulators/vmware3/files/pmap.patch11
2 files changed, 14 insertions, 0 deletions
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index 66bcf43a7aa9..4a4ace5aefcd 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -88,6 +88,9 @@ post-patch:
.if ${OSVERSION} >= 500023
cat ${FILESDIR}/kse.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
.endif
+.if ${OSVERSION} >= 500027
+ cat ${FILESDIR}/pmap.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
+.endif
${CP} ${FILESDIR}/Makefile ${WRKSRC}
${CP} ${FILESDIR}/Makefile.vmmon ${WRKSRC}/vmmon-only/Makefile
${RM} -rf ${WRKSRC}/vmmon-only/linux/
diff --git a/emulators/vmware3/files/pmap.patch b/emulators/vmware3/files/pmap.patch
new file mode 100644
index 000000000000..2a914e47c047
--- /dev/null
+++ b/emulators/vmware3/files/pmap.patch
@@ -0,0 +1,11 @@
+--- vmmon-only/freebsd/hostif.c.orig Tue Dec 4 20:49:08 2001
++++ vmmon-only/freebsd/hostif.c Tue Dec 4 20:49:44 2001
+@@ -170,7 +170,7 @@
+ {
+ #define DEB(x)
+ caddr_t addr = (caddr_t)VPN_2_VA(ppn);
+- pt_entry_t pteptr = (pt_entry_t)vtopte(addr);
++ pt_entry_t *pteptr = vtopte(addr);
+ PTE pte;
+
+ DEB(printf("FindMPN: for page %d address %p(phys %p) pteptr %p", ppn, addr, (caddr_t)vtophys(addr), pteptr));