aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine-doors/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/wine-doors/Makefile')
-rw-r--r--emulators/wine-doors/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/emulators/wine-doors/Makefile b/emulators/wine-doors/Makefile
new file mode 100644
index 000000000000..25ad26161995
--- /dev/null
+++ b/emulators/wine-doors/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: wine-doors
+# Date created: 7 July 2007
+# Whom: ports@mcdermottroe.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= wine-doors
+PORTVERSION= 0.1
+CATEGORIES= emulators
+MASTER_SITES= http://www.wine-doors.org/releases/
+
+MAINTAINER= ports@mcdermottroe.com
+COMMENT= Windows application management for the GNOME Desktop
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/${PYLXML_EGG}:${PORTSDIR}/devel/py-lxml \
+ ${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cairo \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/gtksourceview.so:${PORTSDIR}/x11-toolkits/py-gnome-desktop \
+ bash:${PORTSDIR}/shells/bash \
+ cabextract:${PORTSDIR}/archivers/cabextract \
+ orange:${PORTSDIR}/archivers/orange \
+ unzip:${PORTSDIR}/archivers/unzip \
+ wine:${PORTSDIR}/emulators/wine
+
+USE_PYTHON= 2.4+
+
+NO_BUILD= yes
+
+SUB_FILES= preferences.xml
+
+post-patch:
+ @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} 's|/etc/wine-doors|${PREFIX}/etc/wine-doors|g' \
+ ${WRKSRC}/src/preferences.py
+ @${GREP} -lr '^#!/bin/bash' ${WRKDIR} | ${XARGS} \
+ ${REINPLACE_CMD} 's|^#!/bin/bash|#!${LOCALBASE}/bin/bash|'
+
+do-install:
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKDIR}/preferences.xml ${PREFIX}/etc/${PORTNAME}
+ ${PYTHON_CMD} ${WRKSRC}/setup.py install
+
+.include <bsd.port.pre.mk>
+
+PYLXML_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-lxml/Makefile -V PYLXML_EGG
+
+.include <bsd.port.post.mk>