aboutsummaryrefslogtreecommitdiff
path: root/emulators/xmame/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/xmame/Makefile')
-rw-r--r--emulators/xmame/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index a629c3adaf82..ed3c158298bd 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -31,9 +31,6 @@ WANT_SDL= yes
WANT_GNOME= yes
MAKE_JOBS_UNSAFE= yes
-# Broken on ia-64
-NOT_FOR_ARCHS= ia64
-
# Are we building MAME or MESS? (also set by slave ports)
MAMEMESS?= mame
@@ -112,6 +109,10 @@ ALLDOCS= ${GENERALDOCS} ${XMESSDOCS}
#
.include <bsd.port.pre.mk>
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
.if defined(WITH_ASM68K)
ASM_COMMENT=
.else