aboutsummaryrefslogtreecommitdiff
path: root/emulators/xmame/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/xmame/Makefile')
-rw-r--r--emulators/xmame/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 0b615444cf1c..0d7cc9d19032 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -161,7 +161,7 @@ CFLAGS+= -O3 -Wall -Wno-unused -funroll-loops \
SDLSOUNDCOMMENT= \#
# Option DISPLAY_TARGET
-.if defined(WITH_SDL)
+.if defined(WITH_SDL) || !defined(WITHOUT_SDL)
USE_SDL= sdl
DISPLAY_TARGET= sdl
DISPLAY_METHOD= SDL
@@ -233,7 +233,7 @@ do-configure:
-e "s@^SDL_CONFIG.*@SDL_CONFIG = ${SDL_CONFIG}@g" \
-e "s@^GLLIBS += .*@GLLIBS += ${PTHREAD_LIBS}@g" \
${WRKSRC}/makefile.unix
-.if defined(WITH_SDL)
+.if defined(WITH_SDL) || !defined(WITHOUT_SDL)
${REINPLACE_CMD} -e "s@# JOY_SDL = 1@JOY_SDL = 1@g" ${WRKSRC}/makefile.unix
.endif