aboutsummaryrefslogtreecommitdiff
path: root/emulators/yape/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/yape/Makefile')
-rw-r--r--emulators/yape/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/emulators/yape/Makefile b/emulators/yape/Makefile
new file mode 100644
index 000000000000..108270213176
--- /dev/null
+++ b/emulators/yape/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: yape
+# Date created: 31.10.2002
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= yape
+PORTVERSION= 0.32.3
+CATEGORIES= emulators
+MASTER_SITES= http://www.keepitretro.com/plus4/download/
+DISTNAME= yapeSDL-${PORTVERSION}
+
+MAINTAINER= janos.mohacsi@bsd.hu
+
+LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12
+
+NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_GMAKE= yes
+ALL_TARGET= yape
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG}|" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/yape ${PREFIX}/bin
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.Linux ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>