aboutsummaryrefslogtreecommitdiff
path: root/emulators/yuzu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/yuzu/Makefile')
-rw-r--r--emulators/yuzu/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 6a6b1586e8a0..60d2f8c45ad6 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -2,6 +2,10 @@ PORTNAME= yuzu
PORTVERSION= s20211228
PORTREVISION?= 0
CATEGORIES= emulators
+MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb \
+ LOCAL/jbeich:gamedb
+DISTFILES= ${PORTNAME}/compatibility_list.json:gamedb
+EXTRACT_ONLY= ${DISTFILES:N*\:gamedb:C/\:.*//}
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= 6904f055db88.patch:-p1 # https://github.com/yuzu-emu/yuzu/pull/6598 mainline-merge
@@ -107,6 +111,10 @@ post-patch:
-e 's/@GIT_DESC@/${GH_TAGNAME}/' \
${WRKSRC}/src/common/scm_rev.cpp.in
+post-configure:
+ @${CP} ${DISTFILES:M*\:gamedb:C/\:.*//:S,^,${_DISTDIR},} \
+ ${BUILD_WRKSRC}/dist/compatibility_list/
+
post-patch-VAAPI-off:
@${REINPLACE_CMD} -i .nova '/pkg_check.*libva/d' \
${WRKSRC}/CMakeLists.txt