aboutsummaryrefslogtreecommitdiff
path: root/emulators/yuzu/files/patch-dynarmic
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/yuzu/files/patch-dynarmic')
-rw-r--r--emulators/yuzu/files/patch-dynarmic22
1 files changed, 22 insertions, 0 deletions
diff --git a/emulators/yuzu/files/patch-dynarmic b/emulators/yuzu/files/patch-dynarmic
new file mode 100644
index 000000000000..a5429af85e7d
--- /dev/null
+++ b/emulators/yuzu/files/patch-dynarmic
@@ -0,0 +1,22 @@
+Don't install bundled robin-map in dynarmic bundled in yuzu
+
+===> Checking for items in STAGEDIR missing from pkg-plist
+Error: Orphaned: include/tsl/robin_growth_policy.h
+Error: Orphaned: include/tsl/robin_hash.h
+Error: Orphaned: include/tsl/robin_map.h
+Error: Orphaned: include/tsl/robin_set.h
+Error: Orphaned: share/cmake/tsl-robin-map/tsl-robin-mapConfig.cmake
+Error: Orphaned: share/cmake/tsl-robin-map/tsl-robin-mapConfigVersion.cmake
+Error: Orphaned: share/cmake/tsl-robin-map/tsl-robin-mapTargets.cmake
+
+--- externals/dynarmic/externals/CMakeLists.txt.orig 2021-12-23 11:38:58 UTC
++++ externals/dynarmic/externals/CMakeLists.txt
+@@ -24,7 +24,7 @@ target_include_directories(mp INTERFACE $<BUILD_INTERF
+ # robin-map
+
+ if (NOT TARGET tsl::robin_map)
+- add_subdirectory(robin-map)
++ add_subdirectory(robin-map EXCLUDE_FROM_ALL)
+ endif()
+
+ # vixl