aboutsummaryrefslogtreecommitdiff
path: root/emulators/yuzu/files/patch-sdl2
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/yuzu/files/patch-sdl2')
-rw-r--r--emulators/yuzu/files/patch-sdl226
1 files changed, 16 insertions, 10 deletions
diff --git a/emulators/yuzu/files/patch-sdl2 b/emulators/yuzu/files/patch-sdl2
index 2eb05a0a0049..2a55b9750e86 100644
--- a/emulators/yuzu/files/patch-sdl2
+++ b/emulators/yuzu/files/patch-sdl2
@@ -2,24 +2,24 @@ https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=252371
CMake Error at CMakeLists.txt:397 (find_package):
Could not find a configuration file for package "SDL2" that is compatible
- with requested version "2.0.16".
+ with requested version "2.0.18".
The following configuration files were considered but not accepted:
/usr/local/lib/cmake/SDL2/sdl2-config.cmake, version: 2.0.12
---- CMakeLists.txt.orig 2021-08-14 09:28:59 UTC
+--- CMakeLists.txt.orig 2021-12-06 23:09:30 UTC
+++ CMakeLists.txt
@@ -398,7 +398,7 @@ if (ENABLE_SDL2)
endif()
if (NOT YUZU_USE_BUNDLED_SDL2 AND NOT YUZU_USE_EXTERNAL_SDL2)
-- find_package(SDL2 2.0.16 REQUIRED)
+- find_package(SDL2 2.0.18 REQUIRED)
+ find_package(SDL2 2.0.12 REQUIRED)
# Some installations don't set SDL2_LIBRARIES
if("${SDL2_LIBRARIES}" STREQUAL "")
---- src/input_common/drivers/sdl_driver.cpp.orig 2021-11-27 10:52:08 UTC
+--- src/input_common/drivers/sdl_driver.cpp.orig 2021-12-18 10:33:07 UTC
+++ src/input_common/drivers/sdl_driver.cpp
@@ -39,6 +39,7 @@ class SDLJoystick { (public)
}
@@ -51,7 +51,7 @@ CMake Error at CMakeLists.txt:397 (find_package):
}
+#endif
- BasicMotion GetMotion() {
+ const BasicMotion& GetMotion() const {
return motion;
@@ -362,6 +366,7 @@ void SDLDriver::HandleGameControllerEvent(const SDL_Ev
}
@@ -69,8 +69,8 @@ CMake Error at CMakeLists.txt:397 (find_package):
case SDL_JOYDEVICEREMOVED:
LOG_DEBUG(Input, "Controller removed with Instance_ID {}", event.jdevice.which);
CloseJoystick(SDL_JoystickFromInstanceID(event.jdevice.which));
-@@ -392,7 +398,7 @@ SDLDriver::SDLDriver(const std::string& input_engine_)
-
+@@ -390,7 +396,7 @@ void SDLDriver::CloseJoysticks() {
+ SDLDriver::SDLDriver(std::string input_engine_) : InputEngine(std::move(input_engine_)) {
if (!Settings::values.enable_raw_input) {
// Disable raw input. When enabled this setting causes SDL to die when a web applet opens
- SDL_SetHint(SDL_HINT_JOYSTICK_RAWINPUT, "0");
@@ -78,7 +78,7 @@ CMake Error at CMakeLists.txt:397 (find_package):
}
// Prevent SDL from adding undesired axis
-@@ -400,7 +406,7 @@ SDLDriver::SDLDriver(const std::string& input_engine_)
+@@ -398,12 +404,12 @@ SDLDriver::SDLDriver(std::string input_engine_) : Inpu
// Enable HIDAPI rumble. This prevents SDL from disabling motion on PS4 and PS5 controllers
SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_PS4_RUMBLE, "1");
@@ -87,7 +87,13 @@ CMake Error at CMakeLists.txt:397 (find_package):
SDL_SetHint(SDL_HINT_JOYSTICK_ALLOW_BACKGROUND_EVENTS, "1");
// Use hidapi driver for joycons. This will allow joycons to be detected as a GameController and
-@@ -670,6 +676,7 @@ ButtonBindings SDLDriver::GetNintendoButtonBinding(
+ // not a generic one
+- SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_JOY_CONS, "1");
++ SDL_SetHint("SDL_JOYSTICK_HIDAPI_JOY_CONS", "1");
+
+ // Disable hidapi driver for xbox. Already default on Windows, this causes conflict with native
+ // driver on Linux.
+@@ -672,6 +678,7 @@ ButtonBindings SDLDriver::GetNintendoButtonBinding(
auto sl_button = SDL_CONTROLLER_BUTTON_LEFTSHOULDER;
auto sr_button = SDL_CONTROLLER_BUTTON_RIGHTSHOULDER;
@@ -95,7 +101,7 @@ CMake Error at CMakeLists.txt:397 (find_package):
if (joystick->IsJoyconLeft()) {
sl_button = SDL_CONTROLLER_BUTTON_PADDLE2;
sr_button = SDL_CONTROLLER_BUTTON_PADDLE4;
-@@ -678,6 +685,7 @@ ButtonBindings SDLDriver::GetNintendoButtonBinding(
+@@ -680,6 +687,7 @@ ButtonBindings SDLDriver::GetNintendoButtonBinding(
sl_button = SDL_CONTROLLER_BUTTON_PADDLE3;
sr_button = SDL_CONTROLLER_BUTTON_PADDLE1;
}