aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64-sound/Makefile49
-rw-r--r--emulators/mupen64-sound/distinfo2
-rw-r--r--emulators/mupen64-sound/files/patch-Makefile14
-rw-r--r--emulators/mupen64-sound/pkg-descr16
-rw-r--r--emulators/mupen64-sound/pkg-message9
6 files changed, 91 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 7144beaa62f2..d076abdb0668 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -69,6 +69,7 @@
SUBDIR += mupen64-rsp
SUBDIR += mupen64-sdlaudio
SUBDIR += mupen64-sdlinput
+ SUBDIR += mupen64-sound
SUBDIR += osf1_base
SUBDIR += p-interp
SUBDIR += pcemu
diff --git a/emulators/mupen64-sound/Makefile b/emulators/mupen64-sound/Makefile
new file mode 100644
index 000000000000..3e0f48545fcf
--- /dev/null
+++ b/emulators/mupen64-sound/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: mupen64-sound
+# Date created: 12.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.4
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/${PORTVERSION}/
+PKGNAMESUFFIX= -sound
+DISTNAME= mupen64_sound
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Sound plugin for Mupen64
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gtk12
+USE_GCC= 3.4
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= mupen64_audio
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_DIRS= share/mupen64/plugins
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|linux/soundcard.h|sys/soundcard.h|' ${WRKSRC}/main.c
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon
+LDFLAGS+= -shared -Wl,-Bsymbolic
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CC}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64-sound/distinfo b/emulators/mupen64-sound/distinfo
new file mode 100644
index 000000000000..03ce973010b8
--- /dev/null
+++ b/emulators/mupen64-sound/distinfo
@@ -0,0 +1,2 @@
+MD5 (mupen64_sound.tar.bz2) = 88dfa0045794db7f1fc100b4c7b23125
+SIZE (mupen64_sound.tar.bz2) = 5932
diff --git a/emulators/mupen64-sound/files/patch-Makefile b/emulators/mupen64-sound/files/patch-Makefile
new file mode 100644
index 000000000000..e723a4e55f5e
--- /dev/null
+++ b/emulators/mupen64-sound/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig Sun Jul 4 11:43:39 2004
++++ Makefile Thu Aug 12 16:09:11 2004
+@@ -1,7 +1,7 @@
+-CC = gcc
+-CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
+-LD = gcc
+-LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread
++#CC = gcc
++#CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
++#LD = gcc
++#LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread
+
+ OBJECTS = main.o
+
diff --git a/emulators/mupen64-sound/pkg-descr b/emulators/mupen64-sound/pkg-descr
new file mode 100644
index 000000000000..75e5a47238c0
--- /dev/null
+++ b/emulators/mupen64-sound/pkg-descr
@@ -0,0 +1,16 @@
+Sound plugin for Mupen64
+Tip: Use mupen64-sdlaudio (JttL's SDL plugin) instead!
+-
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64-sound/pkg-message b/emulators/mupen64-sound/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64-sound/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------