aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/basiliskII/Makefile4
-rw-r--r--emulators/grustibus/Makefile7
-rw-r--r--emulators/uae/Makefile3
-rw-r--r--emulators/vx68k/Makefile3
-rw-r--r--emulators/xmame/Makefile3
-rw-r--r--emulators/xsystem35/Makefile9
6 files changed, 17 insertions, 12 deletions
diff --git a/emulators/basiliskII/Makefile b/emulators/basiliskII/Makefile
index 5af883856f82..1362078cf621 100644
--- a/emulators/basiliskII/Makefile
+++ b/emulators/basiliskII/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= lthread.2:${PORTSDIR}/devel/linuxthreads
WRKSRC= ${WRKDIR}/BasiliskII-${PORTVERSION}/src/Unix
USE_X_PREFIX= yes
-USE_GTK= yes
-USE_ESOUND= yes
+USE_GNOMENG= yes
+USE_GNOME= esound gtk12
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --disable-fbdev-dga
diff --git a/emulators/grustibus/Makefile b/emulators/grustibus/Makefile
index 610f1eeed0f8..99c01a78f59b 100644
--- a/emulators/grustibus/Makefile
+++ b/emulators/grustibus/Makefile
@@ -16,15 +16,16 @@ MAINTAINER= verm@drunkmonk.net
RUN_DEPENDS= xmame:${PORTSDIR}/emulators/xmame
LIB_DEPENDS= gnomecanvaspixbuf.1:${PORTSDIR}/graphics/gnomecanvas
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=`${GNOME_CONFIG} --sysconfdir`
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
+.if ${HAVE_GNOME:Mgnomelibs}!=""
+USE_GNOME= gnomelibs libcapplet
.endif
.include <bsd.port.post.mk>
diff --git a/emulators/uae/Makefile b/emulators/uae/Makefile
index 927df41060c5..bb7311718b40 100644
--- a/emulators/uae/Makefile
+++ b/emulators/uae/Makefile
@@ -16,7 +16,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sound --enable-vidmode --enable-dga
USE_XLIB= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/emulators/vx68k/Makefile b/emulators/vx68k/Makefile
index db96286b7aaa..0bd0a8ee7fa2 100644
--- a/emulators/vx68k/Makefile
+++ b/emulators/vx68k/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= vm68k.4:${PORTSDIR}/emulators/libvm68k
USE_MESA= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
LIBTOOLFILES= configure vx68k-gtk/configure
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 02f9dbc5e1c0..386034e8fc0c 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -19,6 +19,7 @@ MAINTAINER?= stijn@win.tue.nl
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GNOMENG= yes
MAN6= x${MAMEMESS}.6
@@ -208,7 +209,7 @@ WITH_ESOUND= no
.if ${WITH_ESOUND:L} == "yes"
ESOUNDCOMMENT=
-USE_ESOUND= yes
+USE_GNOME= esound
.else
ESOUNDCOMMENT=\#\
.endif
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 2da5e3ecafb8..e1285f81b1cd 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -15,8 +15,9 @@ MAINTAINER= sf@FreeBSD.org
USE_AUTOCONF= yes
USE_GMAKE= yes
-USE_GTK= yes
-WANT_ESOUND= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+WANT_GNOME= yes
PKGMESSAGE= ${WRKSRC}/MESSAGE
@@ -50,8 +51,8 @@ CONFIGURE_ARGS= --without-included-gettext \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.if defined(HAVE_ESOUND)
-USE_ESOUND= yes
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME+= esound
CONFIGURE_ARGS+= --enable-audio=oss,esd --with-default-output=esd
.else
CONFIGURE_ARGS+= --enable-audio=oss --with-default-output=oss