aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dynamips-devel/Makefile7
-rw-r--r--emulators/dynamips-devel/files/patch-Makefile11
-rw-r--r--emulators/dynamips/Makefile7
-rw-r--r--emulators/dynamips/files/patch-Makefile11
4 files changed, 20 insertions, 16 deletions
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
index 6c115aeabe58..2b57cfc864f4 100644
--- a/emulators/dynamips-devel/Makefile
+++ b/emulators/dynamips-devel/Makefile
@@ -44,13 +44,10 @@ DYNAMIPS_ARCH= "amd64"
DYNAMIPS_ARCH= "nojit"
.endif
-.if ${OSVERSION} < 500000
+.if ${OSVERSION} < 600029
#
# Requires libpcap 0.9+
-USE_REINPLACE= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's/^HAS_PCAP=1/HAS_PCAP=0/' ${WRKSRC}/Makefile
+MAKE_ENV= HAS_PCAP=0
.endif
.include <bsd.port.post.mk>
diff --git a/emulators/dynamips-devel/files/patch-Makefile b/emulators/dynamips-devel/files/patch-Makefile
index 783bf76598af..5efe9c99054e 100644
--- a/emulators/dynamips-devel/files/patch-Makefile
+++ b/emulators/dynamips-devel/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig Thu Feb 2 00:08:41 2006
-+++ Makefile Tue Feb 14 01:26:49 2006
-@@ -3,7 +3,7 @@
++++ Makefile Tue Feb 14 01:53:31 2006
+@@ -3,26 +3,26 @@
# Replace x86 by amd64 for a build on x86_64.
# Use "nojit" for architectures that are not x86 or x86_64.
@@ -9,7 +9,12 @@
# Change this to 0 if your system doesn't support RFC 2553 extensions
HAS_RFC2553=1
-@@ -15,14 +15,14 @@
+
+ # Change this to 1 if your system has libpcap-0.9.4 or better
+ # (WinPcap is used for Cygwin)
+-HAS_PCAP=1
++HAS_PCAP?=1
+
# Current dynamips release
VERSION=0.2.3c
diff --git a/emulators/dynamips/Makefile b/emulators/dynamips/Makefile
index 6c115aeabe58..2b57cfc864f4 100644
--- a/emulators/dynamips/Makefile
+++ b/emulators/dynamips/Makefile
@@ -44,13 +44,10 @@ DYNAMIPS_ARCH= "amd64"
DYNAMIPS_ARCH= "nojit"
.endif
-.if ${OSVERSION} < 500000
+.if ${OSVERSION} < 600029
#
# Requires libpcap 0.9+
-USE_REINPLACE= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's/^HAS_PCAP=1/HAS_PCAP=0/' ${WRKSRC}/Makefile
+MAKE_ENV= HAS_PCAP=0
.endif
.include <bsd.port.post.mk>
diff --git a/emulators/dynamips/files/patch-Makefile b/emulators/dynamips/files/patch-Makefile
index 783bf76598af..5efe9c99054e 100644
--- a/emulators/dynamips/files/patch-Makefile
+++ b/emulators/dynamips/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig Thu Feb 2 00:08:41 2006
-+++ Makefile Tue Feb 14 01:26:49 2006
-@@ -3,7 +3,7 @@
++++ Makefile Tue Feb 14 01:53:31 2006
+@@ -3,26 +3,26 @@
# Replace x86 by amd64 for a build on x86_64.
# Use "nojit" for architectures that are not x86 or x86_64.
@@ -9,7 +9,12 @@
# Change this to 0 if your system doesn't support RFC 2553 extensions
HAS_RFC2553=1
-@@ -15,14 +15,14 @@
+
+ # Change this to 1 if your system has libpcap-0.9.4 or better
+ # (WinPcap is used for Cygwin)
+-HAS_PCAP=1
++HAS_PCAP?=1
+
# Current dynamips release
VERSION=0.2.3c