aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/gens/Makefile47
-rw-r--r--emulators/gens/distinfo2
-rw-r--r--emulators/gens/files/gens.in26
-rw-r--r--emulators/gens/files/patch-Makefile26
-rw-r--r--emulators/gens/pkg-descr14
-rw-r--r--emulators/gens/pkg-plist20
7 files changed, 136 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 94e1eab76b59..04a3f0a4b3eb 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -29,6 +29,7 @@
SUBDIR += gcube
SUBDIR += generator
SUBDIR += generator-cbiere
+ SUBDIR += gens
SUBDIR += gngb
SUBDIR += gnuboy
SUBDIR += grustibus
diff --git a/emulators/gens/Makefile b/emulators/gens/Makefile
new file mode 100644
index 000000000000..45c454faaf92
--- /dev/null
+++ b/emulators/gens/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: gens
+# Date created: 22 Jun 2005
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gens
+PORTVERSION= 2.12a
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Gens212a1SrcL
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Sega Genesis/CD/32X emulator
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_linux/${PORTNAME}
+USE_ZIP= yes
+USE_SDL= sdl
+USE_GNOME= gtk20
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+ONLY_FOR_ARCHS= i386
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|g++|${CXX}|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|%%LDFLAGS%%|${LDFLAGS}|' ${WRKSRC}/Makefile
+ @${CAT} ${FILESDIR}/gens.in | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' > ${WRKDIR}/gens
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/gens
+ ${MKDIR} ${PREFIX}/share/gens/resource
+ ${INSTALL_SCRIPT} ${WRKDIR}/gens ${PREFIX}/bin/gens
+ ${INSTALL_PROGRAM} ${WRKSRC}/gens ${PREFIX}/share/gens/gens
+ ${INSTALL_DATA} ${WRKSRC}/resource/* ${PREFIX}/share/gens/resource
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_linux/README ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/gens/distinfo b/emulators/gens/distinfo
new file mode 100644
index 000000000000..d61557b21ff7
--- /dev/null
+++ b/emulators/gens/distinfo
@@ -0,0 +1,2 @@
+MD5 (Gens212a1SrcL.zip) = 84b7511333f796633cfd0465c17679f2
+SIZE (Gens212a1SrcL.zip) = 572647
diff --git a/emulators/gens/files/gens.in b/emulators/gens/files/gens.in
new file mode 100644
index 000000000000..e4600cf75700
--- /dev/null
+++ b/emulators/gens/files/gens.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+# gens - gens 2.12a wrapper script
+#
+# 2005 Travis Poppe
+
+USERDIR=$HOME/.gens
+
+if [ -d $USERDIR ]; then
+ echo "gens working directory appears to be $USERDIR/"
+ echo ""
+
+ cd $USERDIR
+ ./gens $*
+ exit
+fi
+
+mkdir $USERDIR
+mkdir $USERDIR/resource
+ln -s %%PREFIX%%/share/gens/gens $USERDIR/gens
+ln -s %%PREFIX%%/share/gens/resource/* $USERDIR/resource
+
+echo "Installed gens to $USERDIR/"
+echo ""
+
+cd $USERDIR
+./gens $*
diff --git a/emulators/gens/files/patch-Makefile b/emulators/gens/files/patch-Makefile
new file mode 100644
index 000000000000..ae53e756d7ce
--- /dev/null
+++ b/emulators/gens/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig Wed Jun 22 16:18:29 2005
++++ Makefile Wed Jun 22 16:19:44 2005
+@@ -59,7 +59,7 @@
+ glade/interface.o\
+ glade/support.o
+
+-GTKCFLAGS=-DWITH_GTK -DGTK_DISABLE_DEPRECATED `pkg-config gtk+-2.0 --cflags`
++GTKCFLAGS=-DWITH_GTK `pkg-config gtk+-2.0 --cflags`
+
+
+ #uncomment this if you want to enable GTK support (default)
+@@ -73,12 +73,12 @@
+ GTKLDFLAGS=`pkg-config gtk+-2.0 --libs`
+
+ #uncomment this if you want to enable GTK support (default)
+-LDFLAGS=-lm `sdl-config --libs` -lz -lstdc++ -s $(GTKLDFLAGS)
++LDFLAGS=-lm `sdl-config --libs` -lz -lstdc++ -s $(GTKLDFLAGS) %%LDFLAGS%%
+ #uncomment this if you want to disable GTK support
+ #LDFLAGS=-lm `sdl-config --libs` -lz -lstdc++ -s
+
+
+-NASMFLAGS=-D__GCC2 -f elf -O3
++NASMFLAGS=-D__GCC2 -f elf
+ CC=gcc
+ CXX=g++
+ TARGET=gens
diff --git a/emulators/gens/pkg-descr b/emulators/gens/pkg-descr
new file mode 100644
index 000000000000..ceb57bd26ddb
--- /dev/null
+++ b/emulators/gens/pkg-descr
@@ -0,0 +1,14 @@
+A Sega Genesis/CD/32X emulator that uses the SDL library and has a GTK
+user interface.
+
+Note: This is not the latest version of gens available for *nix. The
+latest version makes use of the Linux-specific header file 'linux/cdrom.h'
+which causes the build to fail.
+
+Patches to get the latest version working on FreeBSD are more than
+welcome!
+
+WWW: http://gens.consolemul.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/gens/pkg-plist b/emulators/gens/pkg-plist
new file mode 100644
index 000000000000..f95b31ef3f9a
--- /dev/null
+++ b/emulators/gens/pkg-plist
@@ -0,0 +1,20 @@
+bin/gens
+%%DATADIR%%/gens
+%%DATADIR%%/resource/Gens2.ico
+%%DATADIR%%/resource/bitmap1.bmp
+%%DATADIR%%/resource/bmp00000.bmp
+%%DATADIR%%/resource/bmp00001.bmp
+%%DATADIR%%/resource/bmp00002.bmp
+%%DATADIR%%/resource/bmp00003.bmp
+%%DATADIR%%/resource/bmp00004.bmp
+%%DATADIR%%/resource/bmp00005.bmp
+%%DATADIR%%/resource/bmp00006.bmp
+%%DATADIR%%/resource/gens.ico
+%%DATADIR%%/resource/gens_big.bmp
+%%DATADIR%%/resource/gens_small.bmp
+%%DATADIR%%/resource/sonic.ico
+%%DATADIR%%/resource/sonic2.ico
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/resource
+@dirrm %%DATADIR%%