aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile4
-rw-r--r--emulators/qemu-devel/distinfo6
-rw-r--r--emulators/qemu-devel/files/patch-bsdusb.patch17
-rw-r--r--emulators/qemu/Makefile4
-rw-r--r--emulators/qemu/distinfo6
-rw-r--r--emulators/qemu/files/patch-bsdusb.patch17
6 files changed, 24 insertions, 30 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index d805fb573f6f..12ea3d755482 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.8.2s.20061214
+PORTVERSION= 0.8.2s.20061216
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.qemu.org/:release \
http://www.volny.cz/xnavara/qemu/:snapshot \
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
http://people.freebsd.org/~maho/qemu/:misc
-DISTNAME= ${PORTNAME}-snapshot-2006-12-14_05
+DISTNAME= ${PORTNAME}-snapshot-2006-12-16_05
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
DIST_SUBDIR= qemu
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index 36ed78d325bc..a31990655ffc 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,6 +1,6 @@
-MD5 (qemu/qemu-snapshot-2006-12-14_05.tar.bz2) = bcd7f7dec32f8dec6eb5b98068a631b2
-SHA256 (qemu/qemu-snapshot-2006-12-14_05.tar.bz2) = 4111586f06f185c870f0439ca93b46eb089161bd5a42379633b5bd7d10f10469
-SIZE (qemu/qemu-snapshot-2006-12-14_05.tar.bz2) = 1501881
+MD5 (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 95be2bf3a0a76506bef0d71de025014f
+SHA256 (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 1e431b37ce64ba1c982e620eb2f89bc653f891fbf6a99edc28b27726eb92ac8d
+SIZE (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 1502556
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
SIZE (qemu/patch3_cirrus) = 8817
diff --git a/emulators/qemu-devel/files/patch-bsdusb.patch b/emulators/qemu-devel/files/patch-bsdusb.patch
index 6c419328f459..09b90c09c916 100644
--- a/emulators/qemu-devel/files/patch-bsdusb.patch
+++ b/emulators/qemu-devel/files/patch-bsdusb.patch
@@ -59,7 +59,7 @@ Index: qemu/usb-stub.c
+ return NULL;
+}
Index: qemu/usb-bsd.c
-@@ -0,0 +1,603 @@
+@@ -0,0 +1,600 @@
+/*
+ * BSD host USB redirector
+ *
@@ -264,23 +264,20 @@ Index: qemu/usb-bsd.c
+ }
+}
+
-+static int usb_host_handle_data(USBDevice *dev, int pid,
-+ uint8_t devep,
-+ uint8_t *data, int len)
++static int usb_host_handle_data(USBDevice *dev, USBPacket *p)
+{
+ USBHostDevice *s = (USBHostDevice *)dev;
+ int ret, fd, mode;
+ int one = 1, shortpacket = 0, timeout = 50;
+ sigset_t new_mask, old_mask;
++ uint8_t devep = p->devep;
+
+ /* protect data transfers from SIGALRM signal */
+ sigemptyset(&new_mask);
+ sigaddset(&new_mask, SIGALRM);
+ sigprocmask(SIG_BLOCK, &new_mask, &old_mask);
+
-+ /* XXX: optimize and handle all data types by looking at the
-+ config descriptor */
-+ if (pid == USB_TOKEN_IN) {
++ if (p->pid == USB_TOKEN_IN) {
+ devep |= 0x80;
+ mode = O_RDONLY;
+ shortpacket = 1;
@@ -311,10 +308,10 @@ Index: qemu/usb-bsd.c
+ }
+ }
+
-+ if (pid == USB_TOKEN_IN)
-+ ret = read(fd, data, len);
++ if (p->pid == USB_TOKEN_IN)
++ ret = read(fd, p->data, p->len);
+ else
-+ ret = write(fd, data, len);
++ ret = write(fd, p->data, p->len);
+
+ sigprocmask(SIG_SETMASK, &old_mask, NULL);
+
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index d805fb573f6f..12ea3d755482 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.8.2s.20061214
+PORTVERSION= 0.8.2s.20061216
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.qemu.org/:release \
http://www.volny.cz/xnavara/qemu/:snapshot \
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
http://people.freebsd.org/~maho/qemu/:misc
-DISTNAME= ${PORTNAME}-snapshot-2006-12-14_05
+DISTNAME= ${PORTNAME}-snapshot-2006-12-16_05
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
DIST_SUBDIR= qemu
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index 36ed78d325bc..a31990655ffc 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,6 +1,6 @@
-MD5 (qemu/qemu-snapshot-2006-12-14_05.tar.bz2) = bcd7f7dec32f8dec6eb5b98068a631b2
-SHA256 (qemu/qemu-snapshot-2006-12-14_05.tar.bz2) = 4111586f06f185c870f0439ca93b46eb089161bd5a42379633b5bd7d10f10469
-SIZE (qemu/qemu-snapshot-2006-12-14_05.tar.bz2) = 1501881
+MD5 (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 95be2bf3a0a76506bef0d71de025014f
+SHA256 (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 1e431b37ce64ba1c982e620eb2f89bc653f891fbf6a99edc28b27726eb92ac8d
+SIZE (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 1502556
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
SIZE (qemu/patch3_cirrus) = 8817
diff --git a/emulators/qemu/files/patch-bsdusb.patch b/emulators/qemu/files/patch-bsdusb.patch
index 6c419328f459..09b90c09c916 100644
--- a/emulators/qemu/files/patch-bsdusb.patch
+++ b/emulators/qemu/files/patch-bsdusb.patch
@@ -59,7 +59,7 @@ Index: qemu/usb-stub.c
+ return NULL;
+}
Index: qemu/usb-bsd.c
-@@ -0,0 +1,603 @@
+@@ -0,0 +1,600 @@
+/*
+ * BSD host USB redirector
+ *
@@ -264,23 +264,20 @@ Index: qemu/usb-bsd.c
+ }
+}
+
-+static int usb_host_handle_data(USBDevice *dev, int pid,
-+ uint8_t devep,
-+ uint8_t *data, int len)
++static int usb_host_handle_data(USBDevice *dev, USBPacket *p)
+{
+ USBHostDevice *s = (USBHostDevice *)dev;
+ int ret, fd, mode;
+ int one = 1, shortpacket = 0, timeout = 50;
+ sigset_t new_mask, old_mask;
++ uint8_t devep = p->devep;
+
+ /* protect data transfers from SIGALRM signal */
+ sigemptyset(&new_mask);
+ sigaddset(&new_mask, SIGALRM);
+ sigprocmask(SIG_BLOCK, &new_mask, &old_mask);
+
-+ /* XXX: optimize and handle all data types by looking at the
-+ config descriptor */
-+ if (pid == USB_TOKEN_IN) {
++ if (p->pid == USB_TOKEN_IN) {
+ devep |= 0x80;
+ mode = O_RDONLY;
+ shortpacket = 1;
@@ -311,10 +308,10 @@ Index: qemu/usb-bsd.c
+ }
+ }
+
-+ if (pid == USB_TOKEN_IN)
-+ ret = read(fd, data, len);
++ if (p->pid == USB_TOKEN_IN)
++ ret = read(fd, p->data, p->len);
+ else
-+ ret = write(fd, data, len);
++ ret = write(fd, p->data, p->len);
+
+ sigprocmask(SIG_SETMASK, &old_mask, NULL);
+