aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/citra/Makefile2
-rw-r--r--emulators/dolphin-emu/Makefile2
-rw-r--r--emulators/i386-wine-devel/Makefile.inc6
-rw-r--r--emulators/i386-wine/Makefile.inc6
-rw-r--r--emulators/linux_base-c6/Makefile2
-rw-r--r--emulators/linux_base-c7/Makefile2
-rw-r--r--emulators/open-vm-tools/Makefile4
-rw-r--r--emulators/py-nova/Makefile4
-rw-r--r--emulators/qemu-cheri/Makefile1
-rw-r--r--emulators/qemu-ppcnv/Makefile2
-rw-r--r--emulators/qemu-riscv/Makefile8
-rw-r--r--emulators/qemu-sbruno/Makefile14
-rw-r--r--emulators/qemu/Makefile14
-rw-r--r--emulators/rpcs3/Makefile2
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile4
-rw-r--r--emulators/xen-kernel47/Makefile4
16 files changed, 9 insertions, 68 deletions
diff --git a/emulators/citra/Makefile b/emulators/citra/Makefile
index 5cd516e3f2a5..c65b4d50dee5 100644
--- a/emulators/citra/Makefile
+++ b/emulators/citra/Makefile
@@ -17,8 +17,6 @@ LICENSE_FILE_GPLv2+ = ${WRKSRC}/license.txt
LICENSE_FILE_MIT= ${WRKSRC}/externals/enet/LICENSE
LICENSE_FILE_LGPL21+ = ${_LICENSE_STORE}/LGPL21 # soundtouch
-BROKEN_FreeBSD_10= libc++ does not support C++17 features
-
BUILD_DEPENDS= boost-libs>=1.66:devel/boost-libs
USE_GITHUB= yes
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index a37e7daa02dc..4329613e9024 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -11,8 +11,6 @@ COMMENT= Gamecube and Wii Emulator
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/license.txt
-BROKEN_FreeBSD_10= conflicting types for '__hash_table<_Tp, _Hash, _Equal, _Alloc>'
-
# Notes on dependencies:
# - alsa support disabled (not optimal)
# - enet and soundtouch come from Externals/ as Dolphin's versions diverge
diff --git a/emulators/i386-wine-devel/Makefile.inc b/emulators/i386-wine-devel/Makefile.inc
index 9a0557f1ff6a..036e346020e8 100644
--- a/emulators/i386-wine-devel/Makefile.inc
+++ b/emulators/i386-wine-devel/Makefile.inc
@@ -48,7 +48,7 @@ MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-4.7.1.msi:emulators/wine-mono-devel
# Included for OPSYS and OSVERSION
.include <bsd.port.pre.mk>
-.for osrel in 10 11 12
+.for osrel in 11 12
.if ${OSREL:C/\..*//} == ${osrel}
PLIST_SUB+= OSREL${osrel}=""
.if ${PKGNAMESUFFIX} == -devel
@@ -65,7 +65,7 @@ PLIST_SUB+= OSREL${osrel}-DEVEL="@comment "
.endfor
.if ${OPSYS} != FreeBSD || (!(${OSVERSION} < 1100000) && !(${OSVERSION} >= 1101000 && ${OSVERSION} < 1200000) && !(${OSVERSION} >= 1200060 && ${OSVERSION} < 1300000))
-IGNORE= binaries compiled for FreeBSD 10.3+, 11.1+ and -current only
+IGNORE= binaries compiled for FreeBSD 11.2+ only
DISTFILES=
.endif
@@ -83,7 +83,7 @@ ${PLIST}: fetch
port-update:
${RM} ${SLAVEDIR}/distinfo ${SLAVEDIR}/distinfo~ ${SLAVEDIR}/pkg-plist.*
-.for osrel in 10 11 12
+.for osrel in 11 12
${MAKE} fetch OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
${MAKE} makesum OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
${CAT} ${SLAVEDIR}/distinfo >> ${SLAVEDIR}/distinfo~
diff --git a/emulators/i386-wine/Makefile.inc b/emulators/i386-wine/Makefile.inc
index c164570b0569..8f4f4c3f1c65 100644
--- a/emulators/i386-wine/Makefile.inc
+++ b/emulators/i386-wine/Makefile.inc
@@ -49,7 +49,7 @@ PORTSCOUT= limitw:1,even
# Included for OPSYS and OSVERSION
.include <bsd.port.pre.mk>
-.for osrel in 10 11 12
+.for osrel in 11 12
.if ${OSREL:C/\..*//} == ${osrel}
PLIST_SUB+= OSREL${osrel}=""
.else
@@ -58,7 +58,7 @@ PLIST_SUB+= OSREL${osrel}="@comment "
.endfor
.if ${OPSYS} != FreeBSD || (!(${OSVERSION} < 1000000) && !(${OSVERSION} >= 1003000 && ${OSVERSION} < 1100000) && !(${OSVERSION} >= 1101000 && ${OSVERSION} < 1200000) && !(${OSVERSION} >= 1200056 && ${OSVERSION} < 1300000))
-IGNORE= binaries compiled for FreeBSD 10.3+, 11.0+ and -current only
+IGNORE= binaries compiled for FreeBSD 11.2+ only
DISTFILES=
.endif
@@ -75,7 +75,7 @@ ${PLIST}: fetch
port-update:
${RM} ${SLAVEDIR}/distinfo ${SLAVEDIR}/distinfo~ ${SLAVEDIR}/pkg-plist.*
-.for osrel in 10 11 12
+.for osrel in 11 12
${MAKE} fetch OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
${MAKE} makesum OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
${CAT} ${SLAVEDIR}/distinfo >> ${SLAVEDIR}/distinfo~
diff --git a/emulators/linux_base-c6/Makefile b/emulators/linux_base-c6/Makefile
index 3a74a5714e14..3a7778d76055 100644
--- a/emulators/linux_base-c6/Makefile
+++ b/emulators/linux_base-c6/Makefile
@@ -120,7 +120,7 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/gshadow etc/motd \
.include <bsd.port.pre.mk>
-.if ${LINUX_ARCH} == x86_64 && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100105
+.if ${LINUX_ARCH} == x86_64
SYSCTLMIB= kern.features.linux64
.else
SYSCTLMIB= compat.linux.osrelease
diff --git a/emulators/linux_base-c7/Makefile b/emulators/linux_base-c7/Makefile
index 9af49d4ee4e0..99e16b3abc12 100644
--- a/emulators/linux_base-c7/Makefile
+++ b/emulators/linux_base-c7/Makefile
@@ -125,7 +125,7 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/gshadow etc/motd \
.include <bsd.port.pre.mk>
-.if ${LINUX_ARCH} == x86_64 && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100105
+.if ${LINUX_ARCH} == x86_64
SYSCTLMIB= kern.features.linux64
.else
SYSCTLMIB= compat.linux.osrelease
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 4368be4115b0..97a9bd43a072 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -63,10 +63,6 @@ INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1100000
-CFLAGS+= -Wno-unknown-warning-option
-.endif
-
.if ${PORT_OPTIONS:MX11}
CONFLICTS= open-vm-tools-nox11-[0-9]*
.else
diff --git a/emulators/py-nova/Makefile b/emulators/py-nova/Makefile
index 431f7fc7728b..62b43ea543db 100644
--- a/emulators/py-nova/Makefile
+++ b/emulators/py-nova/Makefile
@@ -114,10 +114,6 @@ GROUPS= nova
IGNORE= only supported on FreeBSD
.endif
-.if ${OSVERSION} < 1100055
-IGNORE= only supported on recent FreeBSD 11
-.endif
-
post-extract:
@(cd ${WRKSRC}/etc/nova; ${MV} logging_sample.conf logging.conf.sample)
@(cd ${WRKSRC}/etc/nova; for f in *.conf; do ${MV} $${f} $${f}.sample; done)
diff --git a/emulators/qemu-cheri/Makefile b/emulators/qemu-cheri/Makefile
index 4766b8eb6fb1..d62710fd2f88 100644
--- a/emulators/qemu-cheri/Makefile
+++ b/emulators/qemu-cheri/Makefile
@@ -26,7 +26,6 @@ USES= gettext-runtime gmake libtool makeinfo pkgconfig python:2.7,build
USE_XORG= pixman
USE_GNOME+= glib20
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
-BROKEN_FreeBSD_10= Default toolchain lacks support for .cfi_sections
OPTIONS_DEFINE= DOCS
diff --git a/emulators/qemu-ppcnv/Makefile b/emulators/qemu-ppcnv/Makefile
index 346acadf73c0..bcbe8c52926c 100644
--- a/emulators/qemu-ppcnv/Makefile
+++ b/emulators/qemu-ppcnv/Makefile
@@ -15,8 +15,6 @@ COMMENT= Fork of QEMU with experimental PowerPCNV emulation support
LICENSE= GPLv2
-IGNORE_FreeBSD_10= does not build
-
BUILD_DEPENDS+= ${LOCALBASE}/lib/libfdt.so:sysutils/dtc
USE_GITHUB= yes
diff --git a/emulators/qemu-riscv/Makefile b/emulators/qemu-riscv/Makefile
index c5b859ac1509..fc157c92c2cd 100644
--- a/emulators/qemu-riscv/Makefile
+++ b/emulators/qemu-riscv/Makefile
@@ -50,14 +50,8 @@ CONFIGURE_ARGS=--target-list=riscv64-softmmu,riscv32-softmmu \
PLIST_FILES= bin/qemu-system-riscv32 \
bin/qemu-system-riscv64
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1100000
-IGNORE= does not build
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/riscv32-softmmu/qemu-system-riscv32 ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/riscv64-softmmu/qemu-system-riscv64 ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index fc9840fce189..78e96f648575 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -244,24 +244,10 @@ CONFIGURE_ARGS+= --sparc_cpu=v9
CONFIGURE_ARGS+= --python=${PYTHON_CMD}
-# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
-.if (${OPSYS} == FreeBSD && ${OSVERSION} < 1100000)
-PLIST_SUB+= LINUXBOOT_DMA="@comment "
-.else
PLIST_SUB+= LINUXBOOT_DMA=""
-.endif
post-patch:
@${REINPLACE_CMD} -e '/libs_qga=/s|glib_libs|glib_libs -lintl|' ${WRKSRC}/configure
-# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
-.if (${OPSYS} == FreeBSD && ${OSVERSION} < 1100000)
- @${REINPLACE_CMD} -E \
- -e 's|linuxboot_dma.bin||' \
- ${WRKSRC}/pc-bios/optionrom/Makefile
- @${REINPLACE_CMD} -E \
- -e 's|linuxboot_dma.bin||' \
- ${WRKSRC}/Makefile
-.endif
.if empty(PORT_OPTIONS:MCDROM_DMA)
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/cdrom-dma-patch
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index b49b373fe15b..0e502ea93da7 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -116,12 +116,7 @@ MAKE_ARGS+= ARCH=ppc64
CONFIGURE_ARGS+= --sparc_cpu=v9
.endif
-# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
-.if (${OSVERSION} < 1100000)
-PLIST_SUB+= LINUXBOOT_DMA="@comment "
-.else
PLIST_SUB+= LINUXBOOT_DMA=""
-.endif
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
# but it shouldn't matter much
@@ -144,15 +139,6 @@ post-patch:
@${REINPLACE_CMD} -E \
-e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
${WRKSRC}/scripts/texi2pod.pl
-# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
-.if (${OSVERSION} < 1100000)
- @${REINPLACE_CMD} -E \
- -e 's|linuxboot_dma.bin||' \
- ${WRKSRC}/pc-bios/optionrom/Makefile
- @${REINPLACE_CMD} -E \
- -e 's|linuxboot_dma.bin||' \
- ${WRKSRC}/Makefile
-.endif
post-patch-CDROM_DMA-off:
@${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/include/hw/ide/internal.h
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index bd0a45726771..4c6cc7adb882 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -18,8 +18,6 @@ LICENSE_FILE_BSD3CLAUSE=${WRKSRC_cereal}/LICENSE
LICENSE_FILE_MIT= ${WRKSRC_GSL}/LICENSE
LICENSE_FILE_ZLIB= ${WRKSRC_asmjit}/LICENSE.md
-BROKEN_FreeBSD_10= libc++ does not support C++17 features
-
LIB_DEPENDS= libpng.so:graphics/png \
libavcodec.so:multimedia/ffmpeg
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index efb09ba46c5f..0ba2e3f892b0 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -76,11 +76,7 @@ KMK_ARCH= freebsd.${ARCH}
.include <bsd.port.pre.mk>
-.if ${OSREL:R} >= 11
SYMBOLSUFFIX= debug
-.else
-SYMBOLSUFFIX= symbols
-.endif
PLIST_SUB+= SYMBOLSUFFIX=${SYMBOLSUFFIX}
post-patch:
diff --git a/emulators/xen-kernel47/Makefile b/emulators/xen-kernel47/Makefile
index 2ed1764f942a..b47849a759c7 100644
--- a/emulators/xen-kernel47/Makefile
+++ b/emulators/xen-kernel47/Makefile
@@ -101,10 +101,6 @@ EXTRA_PATCHES= ${FILESDIR}/0001-xen-logdirty-prevent-preemption-if-finished.patc
IGNORE= only supported on FreeBSD
.endif
-.if ${OSVERSION} < 1100055
-IGNORE= only supported on recent FreeBSD 11
-.endif
-
pre-build:
${MAKE_CMD} -C ${WRKSRC}/xen defconfig ${MAKE_ARGS}
# Enable hypervisor hot-patching.