aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux-ePSXe/Makefile4
-rw-r--r--emulators/linux-geepee32/Makefile4
-rw-r--r--emulators/linux-padjoy/Makefile5
-rw-r--r--emulators/linux-peops-softgpu/Makefile4
-rw-r--r--emulators/linux-peops-spu/Makefile4
-rw-r--r--emulators/linux-pete-mesagpu/Makefile4
-rw-r--r--emulators/linux-pete-xgl2gpu/Makefile4
-rw-r--r--emulators/linux-vmware-toolbox2/Makefile2
-rw-r--r--emulators/linux-vmware-toolbox4/Makefile2
-rw-r--r--emulators/linux-vmware-toolbox5/Makefile4
-rw-r--r--emulators/linux-vmware-toolbox6/Makefile4
-rw-r--r--emulators/vmware3/Makefile2
12 files changed, 13 insertions, 30 deletions
diff --git a/emulators/linux-ePSXe/Makefile b/emulators/linux-ePSXe/Makefile
index 9f20ab54ffeb..0ba785e9d395 100644
--- a/emulators/linux-ePSXe/Makefile
+++ b/emulators/linux-ePSXe/Makefile
@@ -16,10 +16,8 @@ DISTNAME= epsxe160lin
MAINTAINER= ports@FreeBSD.org
COMMENT= A Sony Playstation emulator (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
-
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
USE_ZIP= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/emulators/linux-geepee32/Makefile b/emulators/linux-geepee32/Makefile
index 996cf006e9d5..64d9a2ed1a32 100644
--- a/emulators/linux-geepee32/Makefile
+++ b/emulators/linux-geepee32/Makefile
@@ -15,11 +15,9 @@ DISTNAME= ${PORTNAME}_linux_sdl_${PORTVERSION}
MAINTAINER= arundel@h3c.de
COMMENT= The only GP32 emulator for i386
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
-
ONLY_FOR_ARCHS= i386
-USE_XLIB= yes
USE_LINUX= yes
+USE_LINUX_APPS= sdl12 xorglibs
USE_ZIP= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/emulators/linux-padjoy/Makefile b/emulators/linux-padjoy/Makefile
index 05c686fcad87..8d3db52e86d7 100644
--- a/emulators/linux-padjoy/Makefile
+++ b/emulators/linux-padjoy/Makefile
@@ -17,13 +17,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A PSEmu Pro joystick plugin (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk \
- /boot/modules/linux_js.ko:${PORTSDIR}/devel/linux-js
+RUN_DEPENDS= /boot/modules/linux_js.ko:${PORTSDIR}/devel/linux-js
WRKSRC= ${WRKDIR}/padJoy
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/linux-peops-softgpu/Makefile b/emulators/linux-peops-softgpu/Makefile
index b2111bc4d59a..772950f8fc93 100644
--- a/emulators/linux-peops-softgpu/Makefile
+++ b/emulators/linux-peops-softgpu/Makefile
@@ -16,12 +16,10 @@ DISTNAME= gpupeopssoftx${MAJOR}${MINOR}
MAINTAINER= ports@FreeBSD.org
COMMENT= A PSEmu Pro GPU plugin using a software X11 renderer (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
-
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/linux-peops-spu/Makefile b/emulators/linux-peops-spu/Makefile
index 59844ba75a50..151799ffe005 100644
--- a/emulators/linux-peops-spu/Makefile
+++ b/emulators/linux-peops-spu/Makefile
@@ -16,12 +16,10 @@ DISTNAME= spupeopsoss${MAJOR}0${MINOR}
MAINTAINER= ports@FreeBSD.org
COMMENT= A PSEmu Pro SPU plugin using the OSS interface (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
-
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/linux-pete-mesagpu/Makefile b/emulators/linux-pete-mesagpu/Makefile
index 57f8294fbbf1..0c092262ea0d 100644
--- a/emulators/linux-pete-mesagpu/Makefile
+++ b/emulators/linux-pete-mesagpu/Makefile
@@ -16,8 +16,6 @@ DISTNAME= gpupetemesagl${MAJOR}${MINOR}
MAINTAINER= ports@FreeBSD.org
COMMENT= A PSEmu Pro GPU plugin using an OpenGL renderer (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
-
.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
@@ -27,7 +25,7 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_d
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/linux-pete-xgl2gpu/Makefile b/emulators/linux-pete-xgl2gpu/Makefile
index 58bcdaf30a61..c25f328e8e46 100644
--- a/emulators/linux-pete-xgl2gpu/Makefile
+++ b/emulators/linux-pete-xgl2gpu/Makefile
@@ -14,8 +14,6 @@ DISTNAME= gpupetexgl${MAJOR}0${MINOR}
MAINTAINER= ports@FreeBSD.org
COMMENT= A PSEmu Pro GPU plugin using a modern OpenGL renderer (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
-
.if defined(WITH_NVIDIA_GL)
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
.else
@@ -25,7 +23,7 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_d
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/linux-vmware-toolbox2/Makefile b/emulators/linux-vmware-toolbox2/Makefile
index 80720dcec2e4..b80a9903282e 100644
--- a/emulators/linux-vmware-toolbox2/Makefile
+++ b/emulators/linux-vmware-toolbox2/Makefile
@@ -19,7 +19,7 @@ COMMENT=VMware toolbox for guest OS (for VMware 2.x, Linux version)
ONLY_FOR_ARCHS= i386
PLIST_FILES= bin/linux-vmware-toolbox
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
NO_BUILD= yes
.if !defined(BATCH)
IS_INTERACTIVE= yes
diff --git a/emulators/linux-vmware-toolbox4/Makefile b/emulators/linux-vmware-toolbox4/Makefile
index 8b45185e071b..d7b7c58cccb2 100644
--- a/emulators/linux-vmware-toolbox4/Makefile
+++ b/emulators/linux-vmware-toolbox4/Makefile
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/vmware-tools-distrib
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
.if !defined(BATCH)
IS_INTERACTIVE= yes
.endif
diff --git a/emulators/linux-vmware-toolbox5/Makefile b/emulators/linux-vmware-toolbox5/Makefile
index 71bf60afdf7e..bcf07412c8ff 100644
--- a/emulators/linux-vmware-toolbox5/Makefile
+++ b/emulators/linux-vmware-toolbox5/Makefile
@@ -15,8 +15,6 @@ DISTNAME= VMwareTools-${VMWARE_VER}-${BUILD_VER}
MAINTAINER= matusita@FreeBSD.org
COMMENT=VMware toolbox for guest OS (VMware Workstation 5.x, Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
-
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
PLIST_FILES= bin/linux-vmware-toolbox bin/linux-vmware-toolbox-gtk \
@@ -25,7 +23,7 @@ WRKSRC= ${WRKDIR}/vmware-tools-distrib
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
NO_BUILD= yes
.if !defined(BATCH)
IS_INTERACTIVE= yes
diff --git a/emulators/linux-vmware-toolbox6/Makefile b/emulators/linux-vmware-toolbox6/Makefile
index 7f4d89e19ec2..464f638984fb 100644
--- a/emulators/linux-vmware-toolbox6/Makefile
+++ b/emulators/linux-vmware-toolbox6/Makefile
@@ -15,8 +15,6 @@ DISTNAME= VMwareTools-${VMWARE_VER}-${BUILD_VER}
MAINTAINER= matusita@FreeBSD.org
COMMENT=VMware toolbox for guest OS (VMware Workstation 6.x, Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
-
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
PLIST_FILES= bin/linux-vmware-toolbox bin/linux-vmware-toolbox-gtk \
@@ -25,7 +23,7 @@ WRKSRC= ${WRKDIR}/vmware-tools-distrib
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
NO_BUILD= yes
.if !defined(BATCH)
IS_INTERACTIVE= yes
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index ab08158c7a27..dd1a2aa0522a 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -45,7 +45,7 @@ SUB_LIST= BRIDGED="${VMNET_BRIDGED}" \
VMNET1_MINOR="${VMNET1_MINOR}"
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
WRKSRC= ${WRKDIR}/vmware-distrib
GZCAT= ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/extract
MAN1= vmware.1