aboutsummaryrefslogtreecommitdiff
path: root/finance/bitcoin-armory/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/bitcoin-armory/Makefile')
-rw-r--r--finance/bitcoin-armory/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/finance/bitcoin-armory/Makefile b/finance/bitcoin-armory/Makefile
index 829c5cee6c3a..5cc3a56e57f8 100644
--- a/finance/bitcoin-armory/Makefile
+++ b/finance/bitcoin-armory/Makefile
@@ -3,6 +3,7 @@
PORTNAME= BitcoinArmory
PORTVERSION= 0.92.3
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= finance
@@ -23,7 +24,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:${PORTSDIR}/devel
USE_GITHUB= yes
GH_ACCOUNT= etotheipi
-USES= gmake python
+USES= gmake python shebangfix
+SHEBANG_FILES= extras/extractKeysFromWallet.py
USE_GCC= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -34,9 +36,11 @@ ONLY_FOR_ARCHS_REASON= low-level code available only for i386 and amd64
post-patch:
@${REINPLACE_CMD} 's/python-config/$${PYTHON_CONFIG}/' ${WRKSRC}/cppForSwig/Makefile
+
post-stage:
@${SED} -i.bak -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${STAGEDIR}/${LOCALBASE}/bin/armory && \
${RM} -f ${STAGEDIR}/${LOCALBASE}/bin/armory.bak
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/armory/_CppBlockUtils.so