aboutsummaryrefslogtreecommitdiff
path: root/finance/kmymoney-kde4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/kmymoney-kde4/Makefile')
-rw-r--r--finance/kmymoney-kde4/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index 36876da63b8c..0d520ee004a8 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kmymoney2
PORTVERSION= 0.8.9
+PORTREVISION= 1
CATEGORIES= finance
MASTER_SITES= SF
@@ -17,8 +18,19 @@ LIB_DEPENDS= osp.5:${PORTSDIR}/textproc/opensp
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS+= ofx.4:${PORTSDIR}/finance/libofx
+
+.if defined(NOPORTDOCS)
+CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking
+.else
CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking --enable-pdf-docs
+# Add more build-time dependencies to generate the PDF docs
+BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
+ pdfjadetex:${PORTSDIR}/print/jadetex \
+ html2ps:${PORTSDIR}/print/html2ps-letter \
+ dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular
+.endif
+
USE_KDELIBS_VER=3
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -36,7 +48,4 @@ MANCOMPRESSED= yes
DATADIR= ${PREFIX}/share/apps/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
-post-patch:
- ${REINPLACE_CMD} -E -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/configure
-
.include <bsd.port.mk>