aboutsummaryrefslogtreecommitdiff
path: root/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/p5-Business-OnlinePayment-2CheckOut/Makefile')
-rw-r--r--finance/p5-Business-OnlinePayment-2CheckOut/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/finance/p5-Business-OnlinePayment-2CheckOut/Makefile b/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
index fcfe665c414f..8dbf3f83ea86 100644
--- a/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
+++ b/finance/p5-Business-OnlinePayment-2CheckOut/Makefile
@@ -24,4 +24,9 @@ PERL_CONFIGURE= yes
MAN3= Business::OnlinePayment::2CheckOut.3
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ -e '$$_="" if /use 5/;' \
+ ${WRKSRC}/2CheckOut.pm
+
.include <bsd.port.mk>