aboutsummaryrefslogtreecommitdiff
path: root/finance/trytond28_calendar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/trytond28_calendar/Makefile')
-rw-r--r--finance/trytond28_calendar/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/finance/trytond28_calendar/Makefile b/finance/trytond28_calendar/Makefile
new file mode 100644
index 000000000000..e1566b9f2378
--- /dev/null
+++ b/finance/trytond28_calendar/Makefile
@@ -0,0 +1,28 @@
+# Created by: Matthias Petermann <matthias@petermann-it.de>
+# $FreeBSD$
+
+PORTNAME= trytond28_calendar
+PORTVERSION= 2.8.0
+CATEGORIES= finance python
+MASTER_SITES= https://pypi.python.org/packages/source/t/trytond_calendar/ \
+ http://downloads.tryton.org/${PORTVERSION:R}/
+DISTNAME= trytond_calendar-${PORTVERSION}
+
+MAINTAINER= matthias@petermann-it.de
+COMMENT= Tryton Application Platform (Calendar Module)
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= trytond28>=2.8.2:${PORTSDIR}/finance/trytond28 \
+ ${PYTHON_PKGNAMEPREFIX}vobject>=0.8.1:${PORTSDIR}/deskutils/py-vobject \
+ ${PYTHON_PKGNAMEPREFIX}PyWebDAV>=0:${PORTSDIR}/www/py-pywebdav \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=1.5:${PORTSDIR}/devel/py-dateutil
+
+CONFLICTS= trytond_calendar-2.[46].*
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYEASYINSTALL_EGG=${DISTNAME}-py${PYTHON_VER}${PYEASYINSTALL_OSARCH}.egg
+
+.include <bsd.port.mk>