aboutsummaryrefslogtreecommitdiff
path: root/finance/trytond28_party/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/trytond28_party/Makefile')
-rw-r--r--finance/trytond28_party/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/finance/trytond28_party/Makefile b/finance/trytond28_party/Makefile
new file mode 100644
index 000000000000..8d77c077554a
--- /dev/null
+++ b/finance/trytond28_party/Makefile
@@ -0,0 +1,26 @@
+# Created by: Matthias Petermann <matthias@petermann-it.de>
+# $FreeBSD$
+
+PORTNAME= trytond28_party
+PORTVERSION= 2.8.0
+CATEGORIES= finance python
+MASTER_SITES= https://pypi.python.org/packages/source/t/trytond_party/ \
+ http://downloads.tryton.org/${PORTVERSION:R}/
+DISTNAME= trytond_party-${PORTVERSION}
+
+MAINTAINER= matthias@petermann-it.de
+COMMENT= Tryton Application Platform (Party Module)
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= trytond28>=2.8.2:${PORTSDIR}/finance/trytond28 \
+ trytond28_country>=2.8.0:${PORTSDIR}/finance/trytond28_country \
+ ${PYTHON_PKGNAMEPREFIX}vatnumber>=1.0.0:${PORTSDIR}/finance/py-vatnumber
+
+CONFLICTS= trytond_party-2.[46].*
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYEASYINSTALL_EGG=${DISTNAME}-py${PYTHON_VER}${PYEASYINSTALL_OSARCH}.egg
+
+.include <bsd.port.mk>