aboutsummaryrefslogtreecommitdiff
path: root/french/geonext/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'french/geonext/Makefile')
-rw-r--r--french/geonext/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/french/geonext/Makefile b/french/geonext/Makefile
new file mode 100644
index 000000000000..cd41dc773eb6
--- /dev/null
+++ b/french/geonext/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: fr-geonext
+# Date created: 24 July 2003
+# Whom: Andreas Fehlner (fehlner@gmx.de)
+#
+# $FreeBSD$
+#
+
+PORTNAME= geonext
+PORTVERSION= 1.0
+CATEGORIES= french math
+MASTER_SITES= http://geonext.uni-bayreuth.de/content/fr/download/ \
+ http://btmdx8.mat.uni-bayreuth.de/~andi/geonext/fr/
+DISTNAME= geonext_fr
+
+MAINTAINER= fehlner@gmx.de
+COMMENT= Interactive (dynamic) elementary Geometry Software
+
+NO_BUILD= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}
+#USE_JAVA= 1.4
+JAVA= ${JAVA_HOME}/bin/java
+GNAME= geonext-fr
+GLOCATE= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
+DATA= cacerts didmat.crt geonext.html geonext.jar license.txt
+GIF= pixel.gif gx.gif gni.gif gn.gif g.gif x.ico
+
+do-install:
+ ${MKDIR} ${GLOCATE}
+ @${ECHO_MSG} '#!/bin/sh' > ${GLOCATE}/${GNAME}
+ @${ECHO_MSG} '${JAVA} -cp ${GLOCATE}/geonext.jar geonext/Geonext&' >>${GLOCATE}/${GNAME}
+ ${CHMOD} a+x ${GLOCATE}/${GNAME}
+ ${LN} ${GLOCATE}/${GNAME} ${GLOCATE}/geonext
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DATA} ${GLOCATE}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${GIF} ${GLOCATE}
+ ${INSTALL_SCRIPT} ${GLOCATE}/${GNAME} ${PREFIX}/bin
+ @${ECHO_MSG} "------------------------------------------------------"
+ @${ECHO_MSG} "Application: ${GLOCATE}/geonext or geonext-fr"
+ @${ECHO_MSG} "Browser-Applet: ${GLOCATE}/geonext.html"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WWW: http://geonext.uni-bayreuth.de/index?LANG=fr"
+ @${ECHO_MSG} "------------------------------------------------------"
+
+.include <bsd.port.mk>