aboutsummaryrefslogtreecommitdiff
path: root/french/xtel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'french/xtel/Makefile')
-rw-r--r--french/xtel/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/french/xtel/Makefile b/french/xtel/Makefile
new file mode 100644
index 000000000000..3fb21fe6e551
--- /dev/null
+++ b/french/xtel/Makefile
@@ -0,0 +1,65 @@
+# Ports collection makefile for: xtel
+# Date created: Wed Jul 11, 2001
+# Whom: Thierry Thomas (<thierry@thomas.as>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= xtel
+PORTVERSION= 3.3.0
+CATEGORIES= french comms emulators
+MASTER_SITES= http://pficheux.free.fr/xtel/download/
+
+MAINTAINER= thierry@thomas.as
+
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+# Remark: Xtel can serve a network, and emulate TVR and I-Minitel, but this is
+# the first release of this port, and these functionnalities have not (yet)
+# been implemented.
+
+USE_IMAKE= yes
+USE_XPM= yes
+
+.include <bsd.port.pre.mk>
+
+MAN1= xtel.1 xteld.1
+
+.if defined(LANG)
+LANGUE= english
+.endif
+
+DOCS= COPYING COPYRIGHT FAQ.txt HISTOIRE.txt LISEZMOI.txt README_IMINITEL.txt
+PATCH_FILES= Imakefile
+
+post-patch:
+.for FILE in ${PATCH_FILES}
+ @${PERL} -pi -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${WRKSRC}/${FILE}
+.endfor
+ find ${WRKSRC} -type f | xargs ${PERL} -pi -e \
+ "s@#include.*<malloc.h>@#include <stdlib.h>@g"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+ @${ECHO}
+ @(if [ 0${LANGUE} = 0fr ] ; then \
+ ${ECHO_MSG} "La documentation a été installée dans ${DOCSDIR}." ; \
+ else \
+ ${ECHO_MSG} "Documentation installed in ${DOCSDIR}." ; \
+ fi)
+.endif
+ @${TOUCH} ${PREFIX}/lib/X11/xtel/xtel.log
+ @(if [ 0${LANGUE} = 0fr ] ; then \
+ ${CP} ${PKGMESSAGE}-fr ${WRKDIR}/pkg-message ; \
+ else \
+ ${CP} ${PKGMESSAGE} ${WRKDIR} ; \
+ fi)
+ @${ECHO}
+ @${CAT} ${WRKDIR}/pkg-message | ${SED} -e "s:%%PREFIX%%:${PREFIX}:g"
+ @${ECHO}
+
+.include <bsd.port.post.mk>