aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index f4d7ef86d1e6..b2994bda42fc 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.19.5
-PORTREVISION= 1
+PORTVERSION= 7.19.6
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
${MASTER_SITE_SOURCEFORGE} \
@@ -68,7 +67,8 @@ OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
LIBSSH2 "SCP/SFTP support via libssh2" off \
NTLM "NTLM authentication" off \
OPENSSL "OpenSSL support" on \
- PROXY "Proxy support" on
+ PROXY "Proxy support" on \
+ TRACKMEMORY "Enable curl memory diagnostic output" off
.include <bsd.port.pre.mk>
@@ -171,6 +171,10 @@ CONFIGURE_ARGS+= --without-libssh2
CONFIGURE_ARGS+= --enable-debug
.endif
+.if defined(WITH_TRACKMEMORY)
+CONFIGURE_ARGS+= --enable-curldebug
+.endif
+
.if defined(WITH_NTLM)
CONFIGURE_ARGS+= --enable-ntlm
.else