aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 277e77bf4930..473ed01e3337 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -26,21 +26,14 @@ SHLIB_VER= 0
MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
-.if defined(WITH_SSL)
-USE_OPENSSL= RSA
-.endif
-
.include <bsd.port.pre.mk>
-.if defined(USE_OPENSSL)
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
CONFIGURE_ENV+= CPPFLAGS='-I${OPENSSLINC} -I${OPENSSLINC}/openssl' \
LDFLAGS='-L${OPENSSLLIB}'
.endif
-.if defined(OPENSSL_RSAREF)
-CONFIGURE_ENV+= LIBS="-L${OPENSSLLIB} -lcrypto -lRSAglue -L${LOCALBASE}/lib -lrsaref"
-.endif
-
GNU_CONFIGURE= yes
USE_AUTOMAKE= yes
MAKEFILES= Makefile src/Makefile