aboutsummaryrefslogtreecommitdiff
path: root/ftp/curlpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/curlpp/Makefile')
-rw-r--r--ftp/curlpp/Makefile36
1 files changed, 23 insertions, 13 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index f99da9aee57c..4af59e4b4f0c 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -10,30 +10,40 @@ PORTNAME= curlpp
PORTVERSION= 0.7.3
PORTREVISION= 1
CATEGORIES= ftp
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
- http://rrette.com/files/curlpp/curlpp-${PORTVERSION:R}/
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A C++ wrapper for libcurl
-LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
-GNU_CONFIGURE= yes
+OPTIONS_DEFINE= BOOST DOCS EXAMPELS
+
+CONFIGURE_ARGS= --disable-ewarning
CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --disable-ewarning --without-boost
+USE_GNOME= gnomehack
USE_LDCONFIG= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MBOOST}
+BUILD_DEPENDS+= boost-libs>=1.20.0:${PORTSDIR}/devel/boost-libs
+RUN_DEPENDS+= boost-libs>=1.20.0:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS+=--with-boost=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-boost
+.endif
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/README ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/example*.cpp ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/guide.pdf ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/doc/guide.pdf ${DOCSDIR}/
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/examples/README ${WRKSRC}/examples/example*.cpp ${EXAMPLESDIR}/
.endif
.include <bsd.port.mk>