aboutsummaryrefslogtreecommitdiff
path: root/ftp/fineftp-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/fineftp-server/Makefile')
-rw-r--r--ftp/fineftp-server/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/ftp/fineftp-server/Makefile b/ftp/fineftp-server/Makefile
new file mode 100644
index 000000000000..2191f0dcec08
--- /dev/null
+++ b/ftp/fineftp-server/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= fineftp-server
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.13
+CATEGORIES= ftp
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ minimal FTP server library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= asio>0:net/asio
+RUN_DEPENDS= asio>0:net/asio
+
+USES= cmake compiler:c++14-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= continental
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+.include <bsd.port.mk>